summaryrefslogtreecommitdiffstats
path: root/package/hiawatha
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-06-23 23:19:03 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-27 15:39:30 +0200
commit2e076eae55be5566dfdaca4971682b472a564b43 (patch)
treee0582320e8ee903be84e9d65a47413381a93f3c0 /package/hiawatha
parent296c1b84d52e93dd195e0df76dfe77325d6b19c2 (diff)
downloadbuildroot-novena-2e076eae55be5566dfdaca4971682b472a564b43.tar.gz
buildroot-novena-2e076eae55be5566dfdaca4971682b472a564b43.zip
hiawatha: bump to version 9.2
Patch dropped since the polarssl external library option is now upstream. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/hiawatha')
-rw-r--r--package/hiawatha/hiawatha-support-for-external-polarssl.patch61
-rw-r--r--package/hiawatha/hiawatha.mk6
2 files changed, 4 insertions, 63 deletions
diff --git a/package/hiawatha/hiawatha-support-for-external-polarssl.patch b/package/hiawatha/hiawatha-support-for-external-polarssl.patch
deleted file mode 100644
index 5441a524a..000000000
--- a/package/hiawatha/hiawatha-support-for-external-polarssl.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-Enable linking against an external PolarSSL
-
-Hiawatha contains its own copy of the PolarSSL source code, and its
-build system builds this private copy of PolarSSL and links to it. In
-the context of Buildroot, we prefer to link against the PolarSSL built
-externally by the polarssl package.
-
-This patch adds a ENABLE_SSL_EXTERNAL option, which, when used in
-addition to ENABLE_SSL, tells Hiawatha's build system to link against
-the already existing PolarSSL library instead of building its own.
-
-[Gustavo]: Update for version 8.5
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura hiawatha-8.5.orig/CMakeLists.txt hiawatha-8.5/CMakeLists.txt
---- hiawatha-8.5.orig/CMakeLists.txt 2012-09-12 09:29:34.347994799 -0300
-+++ hiawatha-8.5/CMakeLists.txt 2012-09-12 09:33:15.983118183 -0300
-@@ -9,6 +9,7 @@
- option(ENABLE_MONITOR "Enable support for the Hiawatha Monitor." off)
- option(ENABLE_RPROXY "Enable reverse proxy support in Hiawatha." on)
- option(ENABLE_SSL "Enable SSL (PolarSSL) support in Hiawatha." on)
-+option(ENABLE_SSL_EXTERNAL "Enable SSL (PolarSSL) as an external library." off)
- option(ENABLE_TOMAHAWK "Enable Tomahawk in Hiawatha" off)
- option(ENABLE_TOOLKIT "Enable the URL toolkit in Hiawatha" on)
- option(ENABLE_XSLT "Enable XSLT support in Hiawatha." on)
-@@ -88,19 +89,23 @@
-
- # PolarSSL
- if(ENABLE_SSL)
-+ if(NOT ENABLE_SSL_EXTERNAL)
- option(USE_SHARED_POLARSSL_LIBRARY "Build PolarSSL as a shared library." ON)
- set(CMAKE_INSTALL_NAME_DIR ${CMAKE_INSTALL_FULL_LIBDIR}/hiawatha)
- set(LIB_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/hiawatha)
-+ include_directories(polarssl/include)
- add_subdirectory(polarssl)
-+ endif()
- set(POLARSSL_LIBRARY "polarssl")
- endif()
-
- # Hiawatha
--include_directories(${CMAKE_CURRENT_BINARY_DIR} polarssl/include)
- if(ENABLE_XSLT)
- include_directories(${LIBXML2_INCLUDE_DIR} ${LIBXSLT_INCLUDE_DIR})
- endif()
-
-+include_directories(${CMAKE_CURRENT_BINARY_DIR})
-+
- # Configure files
- configure_file(config.h.in config.h)
- foreach (configfile ${config_files_in})
-@@ -121,7 +126,9 @@
- target_link_libraries(hiawatha ${CRYPT_LIBRARY} pthread ${Z_LIBRARY})
- if(ENABLE_SSL)
- target_link_libraries(hiawatha ${POLARSSL_LIBRARY})
-+ if(NOT ENABLE_SSL_EXTERNAL)
- set_target_properties(hiawatha PROPERTIES INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR}/hiawatha)
-+ endif()
- endif()
- if(ENABLE_XSLT)
- target_link_libraries(hiawatha ${LIBXML2_LIBRARIES} ${LIBXSLT_LIBRARIES})
diff --git a/package/hiawatha/hiawatha.mk b/package/hiawatha/hiawatha.mk
index 1ecb0e8a9..4be81490f 100644
--- a/package/hiawatha/hiawatha.mk
+++ b/package/hiawatha/hiawatha.mk
@@ -4,14 +4,16 @@
#
################################################################################
-HIAWATHA_VERSION = 9.1
+HIAWATHA_VERSION = 9.2
HIAWATHA_SITE = http://www.hiawatha-webserver.org/files
HIAWATHA_LICENSE = GPLv2
HIAWATHA_LICENSE_FILES = LICENSE
ifeq ($(BR2_PACKAGE_HIAWATHA_SSL),y)
-HIAWATHA_CONF_OPT += -DENABLE_SSL_EXTERNAL=ON -DENABLE_SSL=ON
+HIAWATHA_CONF_OPT += -DUSE_SYSTEM_POLARSSL=ON
HIAWATHA_DEPENDENCIES += polarssl
+else
+HIAWATHA_CONF_OPT += -DENABLE_SSL=OFF
endif
HIAWATHA_CONF_OPT += \