summaryrefslogtreecommitdiffstats
path: root/package/heirloom-mailx
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-05-12 23:44:18 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-14 21:19:10 +0200
commit89726baea94bc72fe624cd5ef85b07171db0a7ea (patch)
tree868792201b7c183fc7a48aa8bdfdab4d2bc26e4d /package/heirloom-mailx
parentb108e9b5dd8cfbf8d7f02e602993bdc174febc00 (diff)
downloadbuildroot-novena-89726baea94bc72fe624cd5ef85b07171db0a7ea.tar.gz
buildroot-novena-89726baea94bc72fe624cd5ef85b07171db0a7ea.zip
heirloom-mailx: run makeconfig in configure step
The heirloom-mailx Makefile runs makeconfig if this has not been done before. In a parallel build, this means makeconfig may be run several times in parallel because there are two targets that depend on makeconfig. See for instance http://autobuild.buildroot.net/results/d24854be69961f71db189f9d804d4bd2cfa078da To avoid this, run makeconfig in the configure step, which is not parallel. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/heirloom-mailx')
-rw-r--r--package/heirloom-mailx/heirloom-mailx.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/heirloom-mailx/heirloom-mailx.mk b/package/heirloom-mailx/heirloom-mailx.mk
index 2b28a3fc4..b1779c0bb 100644
--- a/package/heirloom-mailx/heirloom-mailx.mk
+++ b/package/heirloom-mailx/heirloom-mailx.mk
@@ -12,6 +12,10 @@ ifeq ($(BR2_PACKAGE_OPENSSL),y)
HEIRLOOM_MAILX_DEPENDENCIES += openssl
endif
+define HEIRLOOM_MAILX_CONFIGURE_CMDS
+ (cd $(@D); $(TARGET_CONFIGURE_OPTS) $(SHELL) ./makeconfig)
+endef
+
define HEIRLOOM_MAILX_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
endef