summaryrefslogtreecommitdiffstats
path: root/package/heirloom-mailx
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-04-17 05:46:56 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-29 20:01:22 +0200
commit7ee5f4483952ccf1625af56a97c38f5b856d5a8c (patch)
tree129a660f6ee7cd9fbbc84cf9605886ce4971e8e7 /package/heirloom-mailx
parent40c20cd40e74c97c8995dbf2ca0d6570b46d9261 (diff)
downloadbuildroot-novena-7ee5f4483952ccf1625af56a97c38f5b856d5a8c.tar.gz
buildroot-novena-7ee5f4483952ccf1625af56a97c38f5b856d5a8c.zip
heirloom-mailx: new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/heirloom-mailx')
-rw-r--r--package/heirloom-mailx/Config.in13
-rw-r--r--package/heirloom-mailx/heirloom-mailx.mk28
2 files changed, 41 insertions, 0 deletions
diff --git a/package/heirloom-mailx/Config.in b/package/heirloom-mailx/Config.in
new file mode 100644
index 000000000..9a871d4f6
--- /dev/null
+++ b/package/heirloom-mailx/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_HEIRLOOM_MAILX
+ bool "heirloom-mailx"
+ help
+ Heirloom mailx (previously known as nail) is a mail user
+ agent for Unix systems.
+
+ It can be used as a command-line mail reader, but also more
+ importantly on embedded systems, as a mail composition
+ program and SMTP client, in order to send e-mail from shell
+ scripts. It supports SMTP authentication (login, plain,
+ cram-md5), SMTPS, MIME encoding of attachements, and more.
+
+ http://heirloom.sourceforge.net/mailx.html
diff --git a/package/heirloom-mailx/heirloom-mailx.mk b/package/heirloom-mailx/heirloom-mailx.mk
new file mode 100644
index 000000000..2b28a3fc4
--- /dev/null
+++ b/package/heirloom-mailx/heirloom-mailx.mk
@@ -0,0 +1,28 @@
+#############################################################
+#
+# heirloom-mailx
+#
+#############################################################
+
+HEIRLOOM_MAILX_VERSION = 12.5
+HEIRLOOM_MAILX_SOURCE = heirloom-mailx_$(HEIRLOOM_MAILX_VERSION).orig.tar.gz
+HEIRLOOM_MAILX_SITE = http://snapshot.debian.org/archive/debian/20110427T035506Z/pool/main/h/heirloom-mailx/
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+HEIRLOOM_MAILX_DEPENDENCIES += openssl
+endif
+
+define HEIRLOOM_MAILX_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define HEIRLOOM_MAILX_INSTALL_TARGET_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+ PREFIX=/usr \
+ UCBINSTALL=$(INSTALL) \
+ STRIP=/bin/true \
+ DESTDIR=$(TARGET_DIR) \
+ install
+endef
+
+$(eval $(call GENTARGETS))