summaryrefslogtreecommitdiffstats
path: root/package/gtest
diff options
context:
space:
mode:
authorStephan Hoffmann <sho@relinux.de>2013-02-05 08:16:08 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-17 23:22:40 +0100
commita42e10c61b19a6054d10fc809460c7e23c46fde7 (patch)
tree79ad18b0e8e7ef6812fc0d51d0d86291fc44311c /package/gtest
parent976e3b2dc4db12a6ac20dbc6d5a523c2929ebdde (diff)
downloadbuildroot-novena-a42e10c61b19a6054d10fc809460c7e23c46fde7.tar.gz
buildroot-novena-a42e10c61b19a6054d10fc809460c7e23c46fde7.zip
New package: gtest
Google's framework for writing C++ tests on a variety of platforms (Linux, Mac OS X, Windows, Cygwin, Windows CE, and Symbian). Based on the xUnit architecture. Supports automatic test discovery, a rich set of assertions, user-defined assertions, death tests, fatal and non-fatal failures, value- and type-parameterized tests, various options for running the tests, and XML test report generation. Gtest also allows to easily build testsuites for C programs. This package allows running testsuites on the target which might be advantgeous in certain cases. http://code.google.com/p/googletest/ [Peter: Tweak Config.in, use GTEST_VERSION in _SOURCE] Signed-off-by: Stephan Hoffmann <sho@relinux.de> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gtest')
-rw-r--r--package/gtest/Config.in24
-rw-r--r--package/gtest/gtest.mk23
2 files changed, 47 insertions, 0 deletions
diff --git a/package/gtest/Config.in b/package/gtest/Config.in
new file mode 100644
index 000000000..c50b5f709
--- /dev/null
+++ b/package/gtest/Config.in
@@ -0,0 +1,24 @@
+config BR2_PACKAGE_GTEST
+ bool "gtest"
+ depends on BR2_USE_WCHAR
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ Google's framework for writing C++ tests on a variety of
+ platforms (Linux, Mac OS X, Windows, Cygwin, Windows CE, and
+ Symbian). Based on the xUnit architecture. Supports
+ automatic test discovery, a rich set of assertions,
+ user-defined assertions, death tests, fatal and non-fatal
+ failures, value- and type-parameterized tests, various
+ options for running the tests, and XML test report
+ generation.
+
+ Gtest also allows to easily build testsuites for C programs.
+
+ This package allows running testsuites on the target which
+ might be advantageous in certain cases.
+
+ http://code.google.com/p/googletest/
+
+comment "gtest requires a toolchain with c++, WCHAR and THREADS support"
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INSTALL_LIBSTDCPP
diff --git a/package/gtest/gtest.mk b/package/gtest/gtest.mk
new file mode 100644
index 000000000..6ede13776
--- /dev/null
+++ b/package/gtest/gtest.mk
@@ -0,0 +1,23 @@
+#############################################################
+#
+# googletest
+#
+#############################################################
+
+GTEST_VERSION = 1.6.0
+GTEST_SOURCE = gtest-$(GTEST_VERSION).zip
+GTEST_SITE = http://googletest.googlecode.com/files/
+GTEST_INSTALL_STAGING = YES
+GTEST_INSTALL_TARGET = NO
+
+define GTEST_EXTRACT_CMDS
+ unzip $(DL_DIR)/$(GTEST_SOURCE) -d $(BUILD_DIR)
+endef
+
+define GTEST_INSTALL_STAGING_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/libgtest.a $(STAGING_DIR)/usr/lib/libgtest.a
+ $(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/include/gtest/
+ cp -rp $(@D)/include/gtest/* $(STAGING_DIR)/usr/include/gtest/
+endef
+
+$(eval $(cmake-package))