summaryrefslogtreecommitdiffstats
path: root/package/gptfdisk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-07 10:45:27 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-10 22:22:55 +0100
commita4b61bf3785283605252876825d49253434da5b9 (patch)
tree2615f4b30a4d54dd49b41fec629650d4cc474b70 /package/gptfdisk
parent8e14c0429d23bde17451b982d5b3d58f3b685fe8 (diff)
downloadbuildroot-novena-a4b61bf3785283605252876825d49253434da5b9.tar.gz
buildroot-novena-a4b61bf3785283605252876825d49253434da5b9.zip
gptfdisk: fix installation step
The installation step was not giving the full destination path even though it was using -D, and it was forgetting to explicitly specify the permissions of the file to install. This commit fixes both of these minor issues. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gptfdisk')
-rw-r--r--package/gptfdisk/gptfdisk.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/gptfdisk/gptfdisk.mk b/package/gptfdisk/gptfdisk.mk
index 656a18761..988eecf08 100644
--- a/package/gptfdisk/gptfdisk.mk
+++ b/package/gptfdisk/gptfdisk.mk
@@ -22,7 +22,7 @@ endef
define GPTFDISK_INSTALL_TARGET_CMDS
for i in $(GPTFDISK_TARGETS_y); do \
- $(INSTALL) -D $(@D)/$$i $(TARGET_DIR)/usr/sbin/; \
+ $(INSTALL) -D -m 0755 $(@D)/$$i $(TARGET_DIR)/usr/sbin/$$i; \
done
endef