summaryrefslogtreecommitdiffstats
path: root/package/gptfdisk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-07 10:45:25 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-10 22:12:19 +0100
commit2a86ea7fc968f297e5b8c6679770d6b5b8fd4646 (patch)
treef8be5f156fe81211e8e8874eaf935984154edec8 /package/gptfdisk
parent29b83f05274d312a0088dcfdfd52fffb65f64422 (diff)
downloadbuildroot-novena-2a86ea7fc968f297e5b8c6679770d6b5b8fd4646.tar.gz
buildroot-novena-2a86ea7fc968f297e5b8c6679770d6b5b8fd4646.zip
gptfdisk: ensure that the package always builds/installs something
Until now, selecting just the gptfdisk package wouldn't do anything. It wouldn't build anything at all, and wouldn't install anything. This is rather odd. So now, we ensure that at least one of the two tools that gptfdisk can build and install is selected. This allows use to factorize a bit the select of util-linux in Config.in, and remove the if condition in the makefile that was preventing the package from being built if no tools was selected. [Peter: Reword commit text] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gptfdisk')
-rw-r--r--package/gptfdisk/Config.in7
-rw-r--r--package/gptfdisk/gptfdisk.mk4
2 files changed, 3 insertions, 8 deletions
diff --git a/package/gptfdisk/Config.in b/package/gptfdisk/Config.in
index 7851dc3dc..0d7e35836 100644
--- a/package/gptfdisk/Config.in
+++ b/package/gptfdisk/Config.in
@@ -3,6 +3,9 @@ config BR2_PACKAGE_GPTFDISK
depends on BR2_LARGEFILE
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_USE_WCHAR # util-linux
+ select BR2_PACKAGE_UTIL_LINUX
+ select BR2_PACKAGE_UTIL_LINUX_LIBUUID
+ select BR2_PACKAGE_GPTFDISK_GDISK if !BR2_PACKAGE_GPTFDISK_SGDISK
help
GPT fdisk (consisting of the gdisk and sgdisk programs) is a
text-mode partitioning tool that works on Globally Unique Identifier
@@ -14,8 +17,6 @@ config BR2_PACKAGE_GPTFDISK
config BR2_PACKAGE_GPTFDISK_GDISK
bool "interactive gdisk"
depends on BR2_PACKAGE_GPTFDISK
- select BR2_PACKAGE_UTIL_LINUX
- select BR2_PACKAGE_UTIL_LINUX_LIBUUID
help
Install the interactive GUID partition table (GPT) manipulator
/usr/sbin/gdisk which is modelled after and quite similar in use
@@ -24,8 +25,6 @@ config BR2_PACKAGE_GPTFDISK_GDISK
config BR2_PACKAGE_GPTFDISK_SGDISK
bool "command line sgdisk"
depends on BR2_PACKAGE_GPTFDISK
- select BR2_PACKAGE_UTIL_LINUX
- select BR2_PACKAGE_UTIL_LINUX_LIBUUID
select BR2_PACKAGE_POPT
help
Install the command-line GUID partition table (GPT) manipulator
diff --git a/package/gptfdisk/gptfdisk.mk b/package/gptfdisk/gptfdisk.mk
index 7755a30c9..2d3cb1add 100644
--- a/package/gptfdisk/gptfdisk.mk
+++ b/package/gptfdisk/gptfdisk.mk
@@ -10,8 +10,6 @@ GPTFDISK_SITE = http://downloads.sourceforge.net/sourceforge/gptfdisk
GPTFDISK_TARGETS_$(BR2_PACKAGE_GPTFDISK_GDISK) += gdisk
GPTFDISK_TARGETS_$(BR2_PACKAGE_GPTFDISK_SGDISK) += sgdisk
-ifneq ($(GPTFDISK_TARGETS_y),)
-
GPTFDISK_DEPENDENCIES += util-linux
ifeq ($(BR2_PACKAGE_GPTFDISK_SGDISK),y)
GPTFDISK_DEPENDENCIES += popt
@@ -33,6 +31,4 @@ define GPTFDISK_UNINSTALL_TARGET_CMDS
rm -f $(addprefix $(TARGET_DIR)/usr/sbin/,$(GPTFDISK_TARGETS_y))
endef
-endif
-
$(eval $(generic-package))