summaryrefslogtreecommitdiffstats
path: root/package/gpsd
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-25 00:01:55 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-25 18:25:42 +0200
commit4c0f75e444846f6436a3c49b40dab9d56032acfb (patch)
tree69096c741bd8814a79a6bdc2d059f7c6ceaf863d /package/gpsd
parent30d2b422e53da8dcb4c13b6fdd47a959607807c5 (diff)
downloadbuildroot-novena-4c0f75e444846f6436a3c49b40dab9d56032acfb.tar.gz
buildroot-novena-4c0f75e444846f6436a3c49b40dab9d56032acfb.zip
gpsd: proper usage of prefix and DESTDIR
prefix should always be /usr, and destdir must be passed as DESTDIR, and in the environment, not as a scons argument. Finally, we pass the sysroot= argument to scons so that it doesn't add -L/usr/lib parameters when compiling. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gpsd')
-rw-r--r--package/gpsd/gpsd.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/gpsd/gpsd.mk b/package/gpsd/gpsd.mk
index c5270bd2b..e96d97979 100644
--- a/package/gpsd/gpsd.mk
+++ b/package/gpsd/gpsd.mk
@@ -17,8 +17,9 @@ GPSD_SCONS_ENV = $(TARGET_CONFIGURE_OPTS)
GPSD_SCONS_OPTS = \
arch=$(ARCH)\
- prefix=$(TARGET_DIR)/usr\
+ prefix=/usr\
chrpath=no\
+ sysroot=$(STAGING_DIR)\
strip=no
ifeq ($(BR2_PACKAGE_NCURSES),y)
@@ -207,9 +208,9 @@ endef
define GPSD_INSTALL_TARGET_CMDS
(cd $(@D); \
$(GPSD_SCONS_ENV) \
+ DESTDIR=$(TARGET_DIR) \
$(SCONS) \
$(GPSD_SCONS_OPTS) \
- destdir=$(TARGET_DIR) \
install)
if [ ! -f $(TARGET_DIR)/etc/init.d/S50gpsd ]; then \
$(INSTALL) -m 0755 -D package/gpsd/S50gpsd $(TARGET_DIR)/etc/init.d/S50gpsd; \
@@ -220,10 +221,9 @@ endef
define GPSD_INSTALL_STAGING_CMDS
(cd $(@D); \
$(GPSD_SCONS_ENV) \
+ DESTDIR=$(STAGING_DIR) \
$(SCONS) \
$(GPSD_SCONS_OPTS) \
- destdir=$(STAGING_DIR) \
- includedir="$(STAGING_DIR)/usr/include" \
install)
endef