summaryrefslogtreecommitdiffstats
path: root/package/gnupg
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-10-15 09:19:55 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-15 10:20:59 +0200
commit260a5820180760d4b00e530041d98eab4bab60fc (patch)
tree942b97246790d158dd5e32027e281b3c71f51d40 /package/gnupg
parent947b57da19e6308fed7f66ba827aa9a46c8c7d73 (diff)
downloadbuildroot-novena-260a5820180760d4b00e530041d98eab4bab60fc.tar.gz
buildroot-novena-260a5820180760d4b00e530041d98eab4bab60fc.zip
package: add gnupg
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gnupg')
-rw-r--r--package/gnupg/Config.in35
-rw-r--r--package/gnupg/gnupg.mk48
2 files changed, 83 insertions, 0 deletions
diff --git a/package/gnupg/Config.in b/package/gnupg/Config.in
new file mode 100644
index 000000000..8ddffaa19
--- /dev/null
+++ b/package/gnupg/Config.in
@@ -0,0 +1,35 @@
+config BR2_PACKAGE_GNUPG
+ bool "gnupg"
+ select BR2_PACKAGE_ZLIB
+ select BR2_PACKAGE_NCURSES
+ help
+ GnuPG is the GNU project's complete and free implementation
+ of the OpenPGP standard as defined by RFC4880. GnuPG allows
+ to encrypt and sign your data and communication, features a
+ versatile key management system as well as access modules
+ for all kinds of public key directories. GnuPG, also known
+ as GPG, is a command line tool with features for easy
+ integration with other applications.
+
+ http://gnupg.org/
+
+if BR2_PACKAGE_GNUPG
+
+config BR2_PACKAGE_GNUPG_GPGV
+ bool "gpgv"
+ help
+ gpgv is an OpenPGP signature verification tool.
+
+ This program is actually a stripped-down version of gpg
+ which is only able to check signatures. It is somewhat
+ smaller than the fully-blown gpg and uses a different (and
+ simpler) way to check that the public keys used to make the
+ signature are valid. There are no configuration files and
+ only a few options are implemented.
+
+config BR2_PACKAGE_GNUPG_GPGSPLIT
+ bool "gpgsplit"
+ help
+ gpgsplit splits an OpenPGP message into packets.
+
+endif
diff --git a/package/gnupg/gnupg.mk b/package/gnupg/gnupg.mk
new file mode 100644
index 000000000..4b5c0a1a4
--- /dev/null
+++ b/package/gnupg/gnupg.mk
@@ -0,0 +1,48 @@
+#############################################################
+#
+# gnupg
+#
+#############################################################
+
+GNUPG_VERSION = 1.4.12
+GNUPG_SOURCE = gnupg-$(GNUPG_VERSION).tar.bz2
+GNUPG_SITE = ftp://ftp.gnupg.org/gcrypt/gnupg
+GNUPG_LICENSE = GPLv3+
+GNUPG_LICENSE_FILES = COPYING
+GNUPG_DEPENDENCIES = zlib ncurses
+GNUPG_CONF_OPT = --disable-rpath --enable-minimal --disable-regex
+
+ifeq ($(BR2_PACKAGE_BZIP2),y)
+GNUPG_CONF_OPT += --enable-bzip2
+GNUPG_DEPENDENCIES += bzip2
+endif
+
+ifeq ($(BR2_PACKAGE_LIBCURL),y)
+GNUPG_CONF_ENV += ac_cv_path__libcurl_config=$(STAGING_DIR)/usr/bin/curl-config
+GNUPG_DEPENDENCIES += libcurl
+else
+GNUPG_CONF_OPT += --without-libcurl
+endif
+
+ifeq ($(BR2_PACKAGE_READLINE),y)
+GNUPG_DEPENDENCIES += readline
+else
+GNUPG_CONF_OPT += --without-readline
+endif
+
+ifneq ($(BR2_PACKAGE_GNUPG_GPGV),y)
+define GNUPG_REMOVE_GPGV
+ rm -f $(TARGET_DIR)/usr/bin/gpgv \
+ $(TARGET_DIR)/usr/share/man/man1/gpgv.1
+endef
+GNUPG_POST_INSTALL_TARGET_HOOKS += GNUPG_REMOVE_GPGV
+endif
+
+ifneq ($(BR2_PACKAGE_GNUPG_GPGSPLIT),y)
+define GNUPG_REMOVE_GPGSPLIT
+ rm -f $(TARGET_DIR)/usr/bin/gpgsplit
+endef
+GNUPG_POST_INSTALL_TARGET_HOOKS += GNUPG_REMOVE_GPGSPLIT
+endif
+
+$(eval $(autotools-package))