summaryrefslogtreecommitdiffstats
path: root/package/gnuchess/gnuchess.mk
diff options
context:
space:
mode:
authorJohn Voltz <john.voltz@gmail.com>2008-03-06 18:10:50 +0000
committerJohn Voltz <john.voltz@gmail.com>2008-03-06 18:10:50 +0000
commitdab3cd675c86d4785f6911f5a386803b92b8a0ec (patch)
treedb50c9fb2c5c1596f4fe7bf1b9e99dc2a466691a /package/gnuchess/gnuchess.mk
parent70d3331748156cff8496ea9b17a0a791d4ce9b78 (diff)
downloadbuildroot-novena-dab3cd675c86d4785f6911f5a386803b92b8a0ec.tar.gz
buildroot-novena-dab3cd675c86d4785f6911f5a386803b92b8a0ec.zip
added gnuchess
Diffstat (limited to 'package/gnuchess/gnuchess.mk')
-rw-r--r--package/gnuchess/gnuchess.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/gnuchess/gnuchess.mk b/package/gnuchess/gnuchess.mk
new file mode 100644
index 000000000..8a64d898a
--- /dev/null
+++ b/package/gnuchess/gnuchess.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# gnuchess
+#
+#############################################################
+GNUCHESS_VERSION = 5.07
+GNUCHESS_SOURCE = gnuchess-$(GNUCHESS_VERSION).tar.gz
+GNUCHESS_SITE = http://ftp.gnu.org/pub/gnu/chess
+GNUCHESS_AUTORECONF = NO
+GNUCHESS_INSTALL_STAGING = NO
+GNUCHESS_INSTALL_TARGET = YES
+
+GNUCHESS_CONF_ENV = ac_cv_func_realloc_0_nonnull=yes ac_cv_func_malloc_0_nonnull=yes
+
+GNUCHESS_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package,gnuchess))
+