summaryrefslogtreecommitdiffstats
path: root/package/gmpc
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-14 09:44:03 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-20 22:34:27 +0200
commit542fbe8520c981f9c96705a57e4263f34f2ab2e6 (patch)
treeebe9b02a339a9d74ed67070fe5c9d8b64e13b3eb /package/gmpc
parent54d64798e1e14b526c3cc1142961972cff9f1e8a (diff)
downloadbuildroot-novena-542fbe8520c981f9c96705a57e4263f34f2ab2e6.tar.gz
buildroot-novena-542fbe8520c981f9c96705a57e4263f34f2ab2e6.zip
Make all package using gettext rely on BR2_NEEDS_GETTEXT
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gmpc')
-rw-r--r--package/gmpc/Config.in4
-rw-r--r--package/gmpc/gmpc.mk3
2 files changed, 4 insertions, 3 deletions
diff --git a/package/gmpc/Config.in b/package/gmpc/Config.in
index a8343617e..056f5a077 100644
--- a/package/gmpc/Config.in
+++ b/package/gmpc/Config.in
@@ -2,8 +2,8 @@ config BR2_PACKAGE_GMPC
bool "gmpc"
depends on BR2_PACKAGE_LIBGTK2
select BR2_PACKAGE_LIBGLIB2
- select BR2_PACKAGE_GETTEXT
- select BR2_PACKAGE_LIBINTL
+ select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
+ select BR2_PACKAGE_LIBINTL if BR2_NEEDS_GETTEXT
select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
select BR2_PACKAGE_LIBMPD
select BR2_PACKAGE_LIBCURL
diff --git a/package/gmpc/gmpc.mk b/package/gmpc/gmpc.mk
index 0db89b902..aa74a2e2f 100644
--- a/package/gmpc/gmpc.mk
+++ b/package/gmpc/gmpc.mk
@@ -11,7 +11,8 @@ GMPC_CONF_ENV = ac_cv_lib_curl_curl_global_init=yes \
ac_cv_path_GOB2=$(GOB2_HOST_BINARY)
GMPC_CONF_OPT = --disable-mmkeys
-GMPC_DEPENDENCIES = libglib2 libgtk2 libglade libcurl libmpd host-gob2 host-intltool
+GMPC_DEPENDENCIES = libglib2 libgtk2 libglade libcurl libmpd host-gob2 host-intltool \
+ $(if $(BR2_NEEDS_GETTEXT),gettext libintl)
ifeq ($(BR2_PACKAGE_XLIB_LIBSM),y)
GMPC_DEPENENCIES += xlib_libSM