summaryrefslogtreecommitdiffstats
path: root/package/glib-networking
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-12-28 09:47:21 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-28 21:56:11 +0100
commit484652cbd8d4a647f7833b2e032d0d37147e8424 (patch)
tree7168de813809f39fb9ba84907302da3151290be9 /package/glib-networking
parent2007e3b1ef5e6e2e646750496c7496ce831aae01 (diff)
downloadbuildroot-novena-484652cbd8d4a647f7833b2e032d0d37147e8424.tar.gz
buildroot-novena-484652cbd8d4a647f7833b2e032d0d37147e8424.zip
glib-networking: fix build failure with gnutls3
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/glib-networking')
-rw-r--r--package/glib-networking/glib-networking.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/glib-networking/glib-networking.mk b/package/glib-networking/glib-networking.mk
index b1eec4d07..e8d71e548 100644
--- a/package/glib-networking/glib-networking.mk
+++ b/package/glib-networking/glib-networking.mk
@@ -25,4 +25,11 @@ else
GLIB_NETWORKING_CONF_OPT += --without-gnutls
endif
+# gnutls 3.x+ doesn't use libgcrypt, it uses nettle/hogweed
+define GLIB_NETWORKING_NO_LIBGCRYPT
+ $(SED) 's:#include <gcrypt.h>::' $(@D)/tls/gnutls/gtlsbackend-gnutls.c
+endef
+
+GLIB_NETWORKING_POST_EXTRACT_HOOKS += GLIB_NETWORKING_NO_LIBGCRYPT
+
$(eval $(autotools-package))