summaryrefslogtreecommitdiffstats
path: root/package/git
diff options
context:
space:
mode:
authorSagaert Johan <sagaert.johan@skynet.be>2013-05-26 09:38:32 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-26 23:26:49 +0200
commit6c183aed401f7228ba6667e170c0642d86706e0f (patch)
tree6a89a9870b10a8e721f6c7dd14f7b6b6c0b25228 /package/git
parentd67b3a54af65ab4818a891458d2d59f91f239f99 (diff)
downloadbuildroot-novena-6c183aed401f7228ba6667e170c0642d86706e0f.tar.gz
buildroot-novena-6c183aed401f7228ba6667e170c0642d86706e0f.zip
git: new package
[Peter: needs largefile, fix license info] Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be> Signed-off-by: Spenser Gilliland <spenser@gillilanding.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/git')
-rw-r--r--package/git/Config.in11
-rw-r--r--package/git/git.mk63
2 files changed, 74 insertions, 0 deletions
diff --git a/package/git/Config.in b/package/git/Config.in
new file mode 100644
index 000000000..31e5ffe5d
--- /dev/null
+++ b/package/git/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_GIT
+ bool "git"
+ depends on BR2_LARGEFILE
+ help
+ Git is a free and open source distributed version control system
+ designed to handle everything from small to very large projects.
+
+ http://git-scm.com
+
+comment "git requires a toolchain with LARGEFILE support"
+ depends on !BR2_LARGEFILE
diff --git a/package/git/git.mk b/package/git/git.mk
new file mode 100644
index 000000000..408456bc9
--- /dev/null
+++ b/package/git/git.mk
@@ -0,0 +1,63 @@
+#############################################################
+#
+# git
+#
+#############################################################
+
+GIT_VERSION = 1.8.3
+GIT_SITE = http://git-core.googlecode.com/files/
+GIT_LICENSE = GPLv2 LGPLv2.1+
+GIT_LICENSE_FILES = COPYING LGPL-2.1
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+ GIT_DEPENDENCIES += zlib
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ GIT_DEPENDENCIES += openssl
+ GIT_CONF_OPT += --with-openssl
+else
+ GIT_CONF_OPT += --without-openssl
+endif
+
+ifeq ($(BR2_PACKAGE_PERL),y)
+ GIT_DEPENDENCIES += perl
+ GIT_CONF_OPT += --with-libpcre
+else
+ GIT_CONF_OPT += --without-libpcre
+endif
+
+ifeq ($(BR2_PACKAGE_CURL),y)
+ GIT_DEPENDENCIES += curl
+ GIT_CONF_OPT += --with-curl
+else
+ GIT_CONF_OPT += --without-curl
+endif
+
+ifeq ($(BR2_PACKAGE_EXPAT),y)
+ GIT_DEPENDENCIES += expat
+ GIT_CONF_OPT += --with-expat
+else
+ GIT_CONF_OPT += --without-expat
+endif
+
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+ GIT_DEPENDENCIES += libiconv
+ GIT_CONF_OPT += --with-iconv=/usr/lib
+else
+ GIT_CONF_OPT += --without-iconv
+endif
+
+ifeq ($(BR2_PACKAGE_TCL),y)
+ GIT_DEPENDENCIES += tcl
+ GIT_CONF_OPT += --with-tcltk
+else
+ GIT_CONF_OPT += --without-tcltk
+endif
+
+# assume yes for these tests, configure will bail out otherwise
+# saying error: cannot run test program while cross compiling
+GIT_CONF_ENV = ac_cv_fread_reads_directories=yes \
+ ac_cv_snprintf_returns_bogus=yes
+
+$(eval $(autotools-package))