summaryrefslogtreecommitdiffstats
path: root/package/gettext
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-01-19 02:06:25 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-20 09:54:25 +0100
commitad0279f0ee51e97bf7dbb70fdd6f14f789f344a8 (patch)
treebec839023c966920d6417689a74bc415f750f394 /package/gettext
parent7f2d0c82c287d6d6e4a5c76f2a32a1cc87585022 (diff)
downloadbuildroot-novena-ad0279f0ee51e97bf7dbb70fdd6f14f789f344a8.tar.gz
buildroot-novena-ad0279f0ee51e97bf7dbb70fdd6f14f789f344a8.zip
gettext: fix static build failure
When static libraries are preferred we don't build dynamic libraries so it fails on the install phase. So don't try to do it for those cases. Fixes: http://autobuild.buildroot.net/results/651537ae1909b039e0cfc5c104ee87f93a9e5792/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gettext')
-rw-r--r--package/gettext/gettext.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/gettext/gettext.mk b/package/gettext/gettext.mk
index 953077d21..204af1089 100644
--- a/package/gettext/gettext.mk
+++ b/package/gettext/gettext.mk
@@ -35,9 +35,12 @@ endif
# When the gettext tools are not enabled in the configuration, we only
# install libintl to the target.
ifeq ($(BR2_PACKAGE_GETTEXT_TOOLS),)
+# When static libs are preferred the .so files aren't created
+ifeq ($(BR2_PREFER_STATIC_LIB),)
define GETTEXT_INSTALL_TARGET_CMDS
cp -dpf $(STAGING_DIR)/usr/lib/libintl*.so* $(TARGET_DIR)/usr/lib/
endef
+endif
# Ditch the tools since they're off and pull other dependencies
define GETTEXT_DISABLE_TOOLS
$(SED) 's/runtime gettext-tools/runtime/' $(@D)/Makefile.in