summaryrefslogtreecommitdiffstats
path: root/package/gesftpserver
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-01-08 17:11:50 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-08 17:15:16 +0100
commitb0e63e5b9a736e70a24e156033663088b4a7f199 (patch)
treead389d87ff1963786224031d872564f12fc9deec /package/gesftpserver
parent88ef92dfcb22f398809dc6bff9e675a6e29afa21 (diff)
downloadbuildroot-novena-b0e63e5b9a736e70a24e156033663088b4a7f199.tar.gz
buildroot-novena-b0e63e5b9a736e70a24e156033663088b4a7f199.zip
package: add green end sftp server
For sftp support in Dropbear or as an alternative for the built in sftp support in openssh (or to use standalone). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gesftpserver')
-rw-r--r--package/gesftpserver/Config.in16
-rw-r--r--package/gesftpserver/gesftpserver.mk27
2 files changed, 43 insertions, 0 deletions
diff --git a/package/gesftpserver/Config.in b/package/gesftpserver/Config.in
new file mode 100644
index 000000000..bc38c51ee
--- /dev/null
+++ b/package/gesftpserver/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_GESFTPSERVER
+ bool "gesftpserver"
+ select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
+ depends on BR2_USE_WCHAR
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ help
+ Green End SFTP Server
+
+ This is an SFTP server supporting up to protocol version 6.
+ It is possible to use it as a drop-in replacement for the
+ OpenSSH server, or to provide sftp support for Dropbear.
+
+ http://www.greenend.org.uk/rjk/sftpserver/
+
+comment "gesftpserver requires a toolchain with WCHAR and threads support"
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/gesftpserver/gesftpserver.mk b/package/gesftpserver/gesftpserver.mk
new file mode 100644
index 000000000..22035a8e0
--- /dev/null
+++ b/package/gesftpserver/gesftpserver.mk
@@ -0,0 +1,27 @@
+#############################################################
+#
+# gesftpserver
+#
+#############################################################
+
+GESFTPSERVER_VERSION = 0.1
+GESFTPSERVER_SOURCE = sftpserver-$(GESFTPSERVER_VERSION).tar.gz
+GESFTPSERVER_SITE = http://www.greenend.org.uk/rjk/sftpserver/
+GESFTPSERVER_LICENSE = GPLv2+
+GESFTPSERVER_LICENSE_FILES = COPYING
+# forgets to link against pthread when cross compiling
+GESFTPSERVER_CONF_ENV = LIBS=-lpthread
+
+# overwrite openssh version if enabled
+GESFTPSERVER_DEPENDENCIES += \
+ $(if $(BR2_ENABLE_LOCALE),,libiconv) \
+ $(if $(BR2_PACKAGE_OPENSSH),openssh)
+
+# openssh/dropbear looks here
+define GESFTPSERVER_ADD_SYMLINK
+ ln -sf gesftpserver $(TARGET_DIR)/usr/libexec/sftp-server
+endef
+
+GESFTPSERVER_POST_INSTALL_TARGET_HOOKS += GESFTPSERVER_ADD_SYMLINK
+
+$(eval $(autotools-package))