summaryrefslogtreecommitdiffstats
path: root/package/gd
diff options
context:
space:
mode:
authorJean-Christian de Rivaz <jc@eclis.ch>2013-01-18 04:55:41 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-18 23:22:27 +0100
commit7b69814d4880c2f58e2aad44f9912468a600708b (patch)
tree1d4413c3ffa6bfcd04acb3df8b6946e05837a43e /package/gd
parenta1b941d789ad1394a4c6b64a5a6872a79350b7ff (diff)
downloadbuildroot-novena-7b69814d4880c2f58e2aad44f9912468a600708b.tar.gz
buildroot-novena-7b69814d4880c2f58e2aad44f9912468a600708b.zip
gd: ensure libpng-config from staging is used
The gd package configure call 'libpng-config' to get the compiler flags required to use the libpng. The configure correctly allow to specify the path of the staging libpng-config by using the ac_cv_path_LIBPNG_CONFIG but the configure.ac call simply 'libpng-config' instead of the specified one. The configure.ac is now modified to call the specified libpng_config. [Peter: explictly pass --without-png instead of auto detect] Signed-off-by: Jean-Christian de Rivaz <jc@eclis.ch> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gd')
-rw-r--r--package/gd/gd-libpng-config.patch30
-rw-r--r--package/gd/gd.mk4
2 files changed, 34 insertions, 0 deletions
diff --git a/package/gd/gd-libpng-config.patch b/package/gd/gd-libpng-config.patch
new file mode 100644
index 000000000..cf8b92e44
--- /dev/null
+++ b/package/gd/gd-libpng-config.patch
@@ -0,0 +1,30 @@
+Call the libpng12-confg and libpng-config specified by
+$LIBPNG12_CONFIG and $LIBPNG_CONFIG variables that are set by
+ac_cv_path_LIBPNG12_CONFIG and ac_cv_path_LIBPNG_CONFIG. This is
+important for cross compiler that need to get the staging settings
+instead of the host settings.
+
+Signed-off-by: Jean-Christian de Rivaz <jc@eclis.ch>
+
+diff -Nura gd-2.0.35.orig/configure.ac gd-2.0.35/configure.ac
+--- gd-2.0.35.orig/configure.ac 2013-01-18 02:00:59.000000000 +0100
++++ gd-2.0.35/configure.ac 2013-01-18 02:01:44.000000000 +0100
+@@ -353,14 +353,14 @@
+ AC_PATH_PROG([LIBPNG12_CONFIG], [libpng12-config])
+ AC_PATH_PROG([LIBPNG_CONFIG], [libpng-config])
+ if test -n "$LIBPNG12_CONFIG"; then
+- libpng_CPPFLAGS=`libpng12-config --cflags`
++ libpng_CPPFLAGS=`$LIBPNG12_CONFIG --cflags`
+ # should be --ldopts, but it's currently broken
+- libpng_LDFLAGS=`libpng12-config --ldflags`
++ libpng_LDFLAGS=`$LIBPNG12_CONFIG --ldflags`
+ libpng_LDFLAGS=`echo " $libpng_LDFLAGS" | sed 's/ -l[[^ ]][[^ ]]*//g'`
+ elif test -n "$LIBPNG_CONFIG"; then
+- libpng_CPPFLAGS=`libpng-config --cflags`
++ libpng_CPPFLAGS=`$LIBPNG_CONFIG --cflags`
+ # should be --ldopts, but it's currently broken
+- libpng_LDFLAGS=`libpng-config --ldflags`
++ libpng_LDFLAGS=`$LIBPNG_CONFIG --ldflags`
+ libpng_LDFLAGS=`echo " $libpng_LDFLAGS" | sed 's/ -l[[^ ]][[^ ]]*//g'`
+ elif test -d "$withval"; then
+ libpng_CPPFLAGS="-I$withval/include"
diff --git a/package/gd/gd.mk b/package/gd/gd.mk
index 972d8dda4..de1f5d171 100644
--- a/package/gd/gd.mk
+++ b/package/gd/gd.mk
@@ -33,6 +33,10 @@ endif
ifeq ($(BR2_PACKAGE_LIBPNG),y)
GD_DEPENDENCIES += libpng
GD_CONF_OPT += --with-png
+GD_CONF_ENV += ac_cv_path_LIBPNG12_CONFIG=""
+GD_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
+else
+GD_CONF_OPT += --without-png
endif
ifeq ($(BR2_PACKAGE_XLIB_LIBXPM),y)