summaryrefslogtreecommitdiffstats
path: root/package/gamin
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-29 10:13:02 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-29 10:13:02 +0000
commit8186a3edee942cbafa487841536b8166955da05f (patch)
treeb37fe3625451dc52deb80f4c2795242aac62bc25 /package/gamin
parent142f88f74634bfe1969050f6e3d950de60f51412 (diff)
downloadbuildroot-novena-8186a3edee942cbafa487841536b8166955da05f.tar.gz
buildroot-novena-8186a3edee942cbafa487841536b8166955da05f.zip
gamin: fix build
Dependencies were wrong, and it didn't build without largefile support.
Diffstat (limited to 'package/gamin')
-rw-r--r--package/gamin/Config.in1
-rw-r--r--package/gamin/gamin.mk8
2 files changed, 7 insertions, 2 deletions
diff --git a/package/gamin/Config.in b/package/gamin/Config.in
index 997585845..d4e9bcc79 100644
--- a/package/gamin/Config.in
+++ b/package/gamin/Config.in
@@ -1,5 +1,6 @@
config BR2_PACKAGE_GAMIN
bool "gamin"
+ select BR2_PACKAGE_LIBGLIB2
help
the File Alteration Monitor
diff --git a/package/gamin/gamin.mk b/package/gamin/gamin.mk
index ea1855bbb..f0a2a1f87 100644
--- a/package/gamin/gamin.mk
+++ b/package/gamin/gamin.mk
@@ -10,13 +10,17 @@ GAMIN_AUTORECONF = NO
GAMIN_INSTALL_STAGING = YES
GAMIN_INSTALL_TARGET = YES
-GAMIN_CONF_OPT = --program-prefix=""
+GAMIN_CONF_OPT = --program-prefix="" --disable-debug
GAMIN_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
GAMIN_CONF_ENV = have_abstract_sockets=no
-GAMIN_DEPENDENCIES = uclibc libgtk2
+ifneq ($(BR2_LARGEFILE),y)
+GAMIN_CONF_ENV += CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
+endif
+
+GAMIN_DEPENDENCIES = uclibc libglib2
$(eval $(call AUTOTARGETS,package,gamin))