summaryrefslogtreecommitdiffstats
path: root/package/freetype
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 17:30:37 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:24:59 +0200
commitda07989b17cbdd4f12576e8ac982c4f7d8540d7b (patch)
treeed36a03cdc07c1053ec38d6b689f66aabed76e32 /package/freetype
parent3d595a601606534bac4db9dd8ff0e9ca22beeafd (diff)
downloadbuildroot-novena-da07989b17cbdd4f12576e8ac982c4f7d8540d7b.tar.gz
buildroot-novena-da07989b17cbdd4f12576e8ac982c4f7d8540d7b.zip
freetype: convert old-style hooks to new-style hooks
The strip of the library is also removed, since this is done globally. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/freetype')
-rw-r--r--package/freetype/freetype.mk20
1 files changed, 13 insertions, 7 deletions
diff --git a/package/freetype/freetype.mk b/package/freetype/freetype.mk
index f19b85486..5a88cca7a 100644
--- a/package/freetype/freetype.mk
+++ b/package/freetype/freetype.mk
@@ -15,17 +15,23 @@ FREETYPE_DEPENDENCIES = host-pkg-config $(if $(BR2_PACKAGE_ZLIB),zlib)
HOST_FREETYPE_DEPENDENCIES = host-pkg-config
-$(eval $(call AUTOTARGETS,package,freetype))
-$(eval $(call AUTOTARGETS,package,freetype,host))
-
-$(FREETYPE_HOOK_POST_INSTALL):
+define FREETYPE_FREETYPE_CONFIG_STAGING_FIXUP
$(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" \
-e "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" \
-e "s,^includedir=.*,includedir=\'$(STAGING_DIR)/usr/include/freetype2\',g" \
-e "s,^libdir=.*,libdir=\'$(STAGING_DIR)/usr/lib\',g" \
$(STAGING_DIR)/usr/bin/freetype-config
- $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libfreetype.so
-ifneq ($(BR2_HAVE_DEVFILES),y)
+endef
+
+FREETYPE_POST_INSTALL_STAGING_HOOKS += FREETYPE_FREETYPE_CONFIG_STAGING_FIXUP
+
+define FREETYPE_FREETYPE_CONFIG_TARGET_REMOVE
rm -f $(TARGET_DIR)/usr/bin/freetype-config
+endef
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+FREETYPE_POST_INSTALL_TARGET_HOOKS += FREETYPE_FREETYPE_CONFIG_TARGET_REMOVE
endif
- touch $@
+
+$(eval $(call AUTOTARGETS,package,freetype))
+$(eval $(call AUTOTARGETS,package,freetype,host))