summaryrefslogtreecommitdiffstats
path: root/package/freescale-imx/firmware-imx/firmware-imx.mk
diff options
context:
space:
mode:
authorHenk Fijnvandraat <h.fijnvandraat@inter.nl.net>2013-05-26 12:08:26 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-29 15:29:50 +0200
commit7aa425e9034069dfeb91361c90256b9cb831bc67 (patch)
treec055ab3a0c97b3a521134606d02ddad0fe3c38ef /package/freescale-imx/firmware-imx/firmware-imx.mk
parentd0fb7b8f817dc35359de011e72b8236ff349494a (diff)
downloadbuildroot-novena-7aa425e9034069dfeb91361c90256b9cb831bc67.tar.gz
buildroot-novena-7aa425e9034069dfeb91361c90256b9cb831bc67.zip
firmware-imx: move to the freescale-imx directory
This commit moves the firmware-imx package to the newly introduced freescale-imx/ directory, and uses the new variables provided by freescale-imx/freescale-imx.mk. Signed-off-by: Henk Fijnvandraat <h.fijnvandraat@inter.nl.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/freescale-imx/firmware-imx/firmware-imx.mk')
-rw-r--r--package/freescale-imx/firmware-imx/firmware-imx.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/package/freescale-imx/firmware-imx/firmware-imx.mk b/package/freescale-imx/firmware-imx/firmware-imx.mk
new file mode 100644
index 000000000..85f8dc29d
--- /dev/null
+++ b/package/freescale-imx/firmware-imx/firmware-imx.mk
@@ -0,0 +1,38 @@
+#############################################################
+#
+# firmware-imx
+#
+#############################################################
+
+FIRMWARE_IMX_VERSION = $(FREESCALE_IMX_VERSION)
+FIRMWARE_IMX_SITE = $(FREESCALE_IMX_MIRROR_SITE)
+FIRMWARE_IMX_SOURCE = firmware-imx-$(FIRMWARE_IMX_VERSION).bin
+FIRMWARE_IMX_LICENSE = Freescale Semiconductor Software License Agreement, \
+ Atheros license (ath6k)
+FIRMWARE_IMX_LICENSE_FILES = licenses/vpu/EULA licenses/ath6k/AR6102/License.txt
+# This is a legal minefield: the EULA specifies that
+# the Board Support Package includes software and hardware (sic!)
+# for which a separate license is needed...
+FIRMWARE_IMX_REDISTRIBUTE = NO
+
+FIRMWARE_IMX_BLOBS = ath6k sdma vpu
+
+# The archive is a shell-self-extractor of a bzipped tar. It happens
+# to extract in the correct directory (firmware-imx-x.y.z)
+# The --force makes sure it doesn't fail if the source dir already exists.
+# The --auto-accept skips the license check - not needed for us
+# because we have legal-info.
+define FIRMWARE_IMX_EXTRACT_CMDS
+ cd $(BUILD_DIR); \
+ sh $(DL_DIR)/$(FIRMWARE_IMX_SOURCE) --force --auto-accept
+endef
+
+
+define FIRMWARE_IMX_INSTALL_TARGET_CMDS
+ mkdir -p $(TARGET_DIR)/lib/firmware
+ for blobdir in $(FIRMWARE_IMX_BLOBS); do \
+ cp -r $(@D)/firmware/$${blobdir} $(TARGET_DIR)/lib/firmware; \
+ done
+endef
+
+$(eval $(generic-package))