summaryrefslogtreecommitdiffstats
path: root/package/fontconfig
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:39:53 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:39:53 +0000
commitee8f2133a57111dd36a6bd667a945dc04a4e419d (patch)
treeb843b7642f0ee904e077b9805bbc2cd02eef78b4 /package/fontconfig
parent8d08091cf8684110fe191e63f3c4167298d19096 (diff)
downloadbuildroot-novena-ee8f2133a57111dd36a6bd667a945dc04a4e419d.tar.gz
buildroot-novena-ee8f2133a57111dd36a6bd667a945dc04a4e419d.zip
add fontconfig package
Diffstat (limited to 'package/fontconfig')
-rw-r--r--package/fontconfig/Config.in7
-rw-r--r--package/fontconfig/fontconfig.mk75
-rw-r--r--package/fontconfig/libdir-la.patch77
3 files changed, 159 insertions, 0 deletions
diff --git a/package/fontconfig/Config.in b/package/fontconfig/Config.in
new file mode 100644
index 000000000..34b5b4e66
--- /dev/null
+++ b/package/fontconfig/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_FONTCONFIG
+ bool "fontconfig"
+ select BR2_PACKAGE_FREETYPE
+ default n
+ help
+
+ http://www.fontconfig.org/
diff --git a/package/fontconfig/fontconfig.mk b/package/fontconfig/fontconfig.mk
new file mode 100644
index 000000000..8e3c3e843
--- /dev/null
+++ b/package/fontconfig/fontconfig.mk
@@ -0,0 +1,75 @@
+#############################################################
+#
+# fontconfig
+#
+#############################################################
+FONTCONFIG_VERSION:=2.4.2
+FONTCONFIG_SOURCE:=fontconfig-$(FONTCONFIG_VERSION).tar.gz
+FONTCONFIG_SITE:=http://fontconfig.org/release
+FONTCONFIG_CAT:=$(ZCAT)
+FONTCONFIG_DIR:=$(BUILD_DIR)/fontconfig-$(FONTCONFIG_VERSION)
+
+$(DL_DIR)/$(FONTCONFIG_SOURCE):
+ $(WGET) -P $(DL_DIR) $(FONTCONFIG_SITE)/$(FONTCONFIG_SOURCE)
+
+fontconfig-source: $(DL_DIR)/$(FONTCONFIG_SOURCE)
+
+$(FONTCONFIG_DIR)/.unpacked: $(DL_DIR)/$(FONTCONFIG_SOURCE)
+ $(FONTCONFIG_CAT) $(DL_DIR)/$(FONTCONFIG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ touch $(FONTCONFIG_DIR)/.unpacked
+
+$(FONTCONFIG_DIR)/.configured: $(FONTCONFIG_DIR)/.unpacked
+ (cd $(FONTCONFIG_DIR); \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS) " \
+ CCexe="$(HOSTCC)" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --with-arch=$(GNU_TARGET_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ );
+ touch $(FONTCONFIG_DIR)/.configured
+
+$(FONTCONFIG_DIR)/.compiled: $(FONTCONFIG_DIR)/.configured
+ $(MAKE) CCexe="$(HOSTCC)" -C $(FONTCONFIG_DIR)
+ touch $(FONTCONFIG_DIR)/.compiled
+
+$(STAGING_DIR)/lib/libfontconfig.so: $(FONTCONFIG_DIR)/.compiled
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(FONTCONFIG_DIR) install
+ $(SED) "s,^libdir=.*,libdir=\'$(STAGING_DIR)/lib\',g" $(STAGING_DIR)/lib/libfontconfig.la
+ touch -c $(STAGING_DIR)/lib/libfontconfig.so
+
+$(TARGET_DIR)/lib/libfontconfig.so: $(STAGING_DIR)/lib/libfontconfig.so
+ cp -dpf $(STAGING_DIR)/lib/libfontconfig.so* $(TARGET_DIR)/lib/
+ -$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libfontconfig.so
+
+fontconfig: uclibc freetype $(TARGET_DIR)/lib/libfontconfig.so
+
+fontconfig-clean:
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(FONTCONFIG_DIR) uninstall
+ -$(MAKE) -C $(FONTCONFIG_DIR) clean
+
+fontconfig-dirclean:
+ rm -rf $(FONTCONFIG_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_FONTCONFIG)),y)
+TARGETS+=fontconfig
+endif
diff --git a/package/fontconfig/libdir-la.patch b/package/fontconfig/libdir-la.patch
new file mode 100644
index 000000000..cc6a377eb
--- /dev/null
+++ b/package/fontconfig/libdir-la.patch
@@ -0,0 +1,77 @@
+--- fontconfig/builds/unix/ltmain.sh.orig 2006-04-20 08:27:27.000000000 -0600
++++ fontconfig/builds/unix/ltmain.sh 2007-01-13 14:26:01.000000000 -0700
+@@ -273,8 +273,9 @@
+ # line option must be used.
+ if test -z "$tagname"; then
+ $echo "$modename: unable to infer tagged configuration"
+- $echo "$modename: specify a tag with \`--tag'" 1>&2
+- exit $EXIT_FAILURE
++ $echo "$modename: defaulting to \`CC'"
++ $echo "$modename: if this is not correct, specify a tag with \`--tag'"
++# exit $EXIT_FAILURE
+ # else
+ # $echo "$modename: using $tagname tagged configuration"
+ fi
+@@ -2404,8 +2405,14 @@
+ absdir="$abs_ladir"
+ libdir="$abs_ladir"
+ else
+- dir="$libdir"
+- absdir="$libdir"
++ # Adding 'libdir' from the .la file to our library search paths
++ # breaks crosscompilation horribly. We cheat here and don't add
++ # it, instead adding the path where we found the .la. -CL
++ dir="$abs_ladir"
++ absdir="$abs_ladir"
++ libdir="$abs_ladir"
++ #dir="$libdir"
++ #absdir="$libdir"
+ fi
+ test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes
+ else
+@@ -2886,6 +2893,16 @@
+ esac
+ if grep "^installed=no" $deplib > /dev/null; then
+ path="$absdir/$objdir"
++# This interferes with crosscompilation. -CL
++# else
++# eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
++# if test -z "$libdir"; then
++# $echo "$modename: \`$deplib' is not a valid libtool archive" 1>&2
++# exit 1
++# fi
++# if test "$absdir" != "$libdir"; then
++# $echo "$modename: warning: \`$deplib' seems to be moved" 1>&2
++# fi
+ else
+ eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
+ if test -z "$libdir"; then
+@@ -5598,6 +5615,10 @@
+ # Replace all uninstalled libtool libraries with the installed ones
+ newdependency_libs=
+ for deplib in $dependency_libs; do
++ # Replacing uninstalled with installed can easily break crosscompilation,
++ # since the installed path is generally the wrong architecture. -CL
++ newdependency_libs="$newdependency_libs $deplib"
++ continue
+ case $deplib in
+ *.la)
+ name=`$echo "X$deplib" | $Xsed -e 's%^.*/%%'`
+@@ -5919,10 +5940,13 @@
+ # At present, this check doesn't affect windows .dll's that
+ # are installed into $libdir/../bin (currently, that works fine)
+ # but it's something to keep an eye on.
+- if test "$inst_prefix_dir" = "$destdir"; then
+- $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
+- exit $EXIT_FAILURE
+- fi
++ #
++ # This breaks install into our staging area. -PB
++ #
++ # if test "$inst_prefix_dir" = "$destdir"; then
++ # $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
++ # exit $EXIT_FAILURE
++ # fi
+
+ if test -n "$inst_prefix_dir"; then
+ # Stick the inst_prefix_dir data into the link command.