summaryrefslogtreecommitdiffstats
path: root/package/fontconfig
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-15 21:26:43 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-15 21:26:43 +0000
commit9178347a602d392a485a32da11c4491604319ec5 (patch)
tree1b4119f4b0f8ec034ef4d66383bf4040d3feafb3 /package/fontconfig
parent8564ba689d507b50ca09ebebe121304bc827cffc (diff)
downloadbuildroot-novena-9178347a602d392a485a32da11c4491604319ec5.tar.gz
buildroot-novena-9178347a602d392a485a32da11c4491604319ec5.zip
teach fontconfig to actually apply its patches
Diffstat (limited to 'package/fontconfig')
-rw-r--r--package/fontconfig/fontconfig.mk4
-rw-r--r--package/fontconfig/libdir-la.patch4
2 files changed, 6 insertions, 2 deletions
diff --git a/package/fontconfig/fontconfig.mk b/package/fontconfig/fontconfig.mk
index 8e3c3e843..27f529ad6 100644
--- a/package/fontconfig/fontconfig.mk
+++ b/package/fontconfig/fontconfig.mk
@@ -16,6 +16,8 @@ fontconfig-source: $(DL_DIR)/$(FONTCONFIG_SOURCE)
$(FONTCONFIG_DIR)/.unpacked: $(DL_DIR)/$(FONTCONFIG_SOURCE)
$(FONTCONFIG_CAT) $(DL_DIR)/$(FONTCONFIG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ toolchain/patch-kernel.sh $(FONTCONFIG_DIR) package/fontconfig/ \*.patch*
+ $(CONFIG_UPDATE) $(FONTCONFIG_DIR)
touch $(FONTCONFIG_DIR)/.unpacked
$(FONTCONFIG_DIR)/.configured: $(FONTCONFIG_DIR)/.unpacked
@@ -54,6 +56,8 @@ $(STAGING_DIR)/lib/libfontconfig.so: $(FONTCONFIG_DIR)/.compiled
$(TARGET_DIR)/lib/libfontconfig.so: $(STAGING_DIR)/lib/libfontconfig.so
cp -dpf $(STAGING_DIR)/lib/libfontconfig.so* $(TARGET_DIR)/lib/
+ mkdir -p $(TARGET_DIR)/etc/fonts
+ cp $(STAGING_DIR)/etc/fonts/fonts.conf $(TARGET_DIR)/etc/fonts/
-$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libfontconfig.so
fontconfig: uclibc freetype $(TARGET_DIR)/lib/libfontconfig.so
diff --git a/package/fontconfig/libdir-la.patch b/package/fontconfig/libdir-la.patch
index cc6a377eb..672e96d4b 100644
--- a/package/fontconfig/libdir-la.patch
+++ b/package/fontconfig/libdir-la.patch
@@ -1,5 +1,5 @@
---- fontconfig/builds/unix/ltmain.sh.orig 2006-04-20 08:27:27.000000000 -0600
-+++ fontconfig/builds/unix/ltmain.sh 2007-01-13 14:26:01.000000000 -0700
+--- fontconfig/ltmain.sh.orig 2006-04-20 08:27:27.000000000 -0600
++++ fontconfig/ltmain.sh 2007-01-13 14:26:01.000000000 -0700
@@ -273,8 +273,9 @@
# line option must be used.
if test -z "$tagname"; then