summaryrefslogtreecommitdiffstats
path: root/package/fontconfig
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-16 08:10:27 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-16 08:10:27 +0000
commit7cb000f5d7f39b93449de9e014e241142162ec55 (patch)
treeeedc31bc49e291b56fab8fac5ef169aba7b15b32 /package/fontconfig
parent0105ad9699e291d1203f204c3270d372e60602f8 (diff)
downloadbuildroot-novena-7cb000f5d7f39b93449de9e014e241142162ec55.tar.gz
buildroot-novena-7cb000f5d7f39b93449de9e014e241142162ec55.zip
Add in a few useful bits for font handling
Diffstat (limited to 'package/fontconfig')
-rw-r--r--package/fontconfig/fontconfig.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/fontconfig/fontconfig.mk b/package/fontconfig/fontconfig.mk
index 27f529ad6..49e4b70b2 100644
--- a/package/fontconfig/fontconfig.mk
+++ b/package/fontconfig/fontconfig.mk
@@ -59,6 +59,12 @@ $(TARGET_DIR)/lib/libfontconfig.so: $(STAGING_DIR)/lib/libfontconfig.so
mkdir -p $(TARGET_DIR)/etc/fonts
cp $(STAGING_DIR)/etc/fonts/fonts.conf $(TARGET_DIR)/etc/fonts/
-$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libfontconfig.so
+ mkdir -p $(TARGET_DIR)/var/cache/fontconfig
+ mkdir -p $(TARGET_DIR)/usr/bin
+ cp -a $(STAGING_DIR)/usr/bin/fc-cache $(TARGET_DIR)/usr/bin/
+ -$(STRIP) --strip-unneeded $(TARGET_DIR)/usr/bin/fc-cache
+ cp -a $(STAGING_DIR)/usr/bin/fc-list $(TARGET_DIR)/usr/bin/
+ -$(STRIP) --strip-unneeded $(TARGET_DIR)/usr/bin/fc-list
fontconfig: uclibc freetype $(TARGET_DIR)/lib/libfontconfig.so