summaryrefslogtreecommitdiffstats
path: root/package/fontconfig
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2008-11-11 19:38:10 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2008-11-11 19:38:10 +0000
commit14520e6fa3dd68cd491af4c1423bb0fd91ac740e (patch)
tree4d58ce97cfd9d369c482f56387017a73569c37a5 /package/fontconfig
parentb741302a0117aac90199f6e1adf8515ff0de163d (diff)
downloadbuildroot-novena-14520e6fa3dd68cd491af4c1423bb0fd91ac740e.tar.gz
buildroot-novena-14520e6fa3dd68cd491af4c1423bb0fd91ac740e.zip
Add a parallel compilation fix for fontconfig
This patch adds a patch to fix bug https://bugs.freedesktop.org/show_bug.cgi?id=16464 affecting parallel compilation of fontconfig. The patch is the one proposed in the bugzilla entry, available at https://bugs.freedesktop.org/attachment.cgi?id=17294. Without this patch, the compilation (at BR2_JLEVEL > 1) of fontconfig sometimes fails with: In file included from fc-case.c:25: ../src/fcint.h:118:21: error: fcalias.h: No such file or directory Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/fontconfig')
-rw-r--r--package/fontconfig/fontconfig-2.6.0-parallel-compilation-fix.patch26
-rw-r--r--package/fontconfig/fontconfig.mk2
2 files changed, 27 insertions, 1 deletions
diff --git a/package/fontconfig/fontconfig-2.6.0-parallel-compilation-fix.patch b/package/fontconfig/fontconfig-2.6.0-parallel-compilation-fix.patch
new file mode 100644
index 000000000..56623cf77
--- /dev/null
+++ b/package/fontconfig/fontconfig-2.6.0-parallel-compilation-fix.patch
@@ -0,0 +1,26 @@
+---
+ fc-case/Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+Index: fontconfig-2.6.0/fc-case/Makefile.am
+===================================================================
+--- fontconfig-2.6.0.orig/fc-case/Makefile.am
++++ fontconfig-2.6.0/fc-case/Makefile.am
+@@ -36,6 +36,8 @@
+
+ noinst_MANS=fc-case.man
+
++noinst_HEADERS=$(TARG)
++
+ fc_case_SRCS= \
+ fc-case.c \
+ fccaseint.h \
+@@ -52,7 +54,7 @@
+
+ ALIAS_FILES = fcalias.h fcaliastail.h
+
+-BUILT_SOURCES = $(ALIAS_FILES) $(TARG)
++BUILT_SOURCES = $(ALIAS_FILES)
+
+ $(ALIAS_FILES):
+ touch $(ALIAS_FILES)
diff --git a/package/fontconfig/fontconfig.mk b/package/fontconfig/fontconfig.mk
index 4ed9985b6..8e5577aa8 100644
--- a/package/fontconfig/fontconfig.mk
+++ b/package/fontconfig/fontconfig.mk
@@ -6,7 +6,7 @@
FONTCONFIG_VERSION = 2.6.0
FONTCONFIG_SOURCE = fontconfig-$(FONTCONFIG_VERSION).tar.gz
FONTCONFIG_SITE = http://fontconfig.org/release
-FONTCONFIG_AUTORECONF = NO
+FONTCONFIG_AUTORECONF = YES
FONTCONFIG_INSTALL_STAGING = YES
FONTCONFIG_INSTALL_TARGET = YES