summaryrefslogtreecommitdiffstats
path: root/package/fltk/fltk-1.1.7-bail-out-on-error.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-21 16:11:25 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-21 16:14:17 +0200
commit584921cb87b66f6c2dd8d080593137ed64a529d0 (patch)
treedc178785fa0484cf3527e6883acc65a13d21e604 /package/fltk/fltk-1.1.7-bail-out-on-error.patch
parentf3122259e2cbbc0be0fc02820a146b4e4f48bef6 (diff)
downloadbuildroot-novena-584921cb87b66f6c2dd8d080593137ed64a529d0.tar.gz
buildroot-novena-584921cb87b66f6c2dd8d080593137ed64a529d0.zip
fltk: fix build
The build of fltk was failing due to an issue in the usage of scandir(). This issue is fixed by a new patch, fltk-1.1.7-scandir-fix.patch. Moreover, this problem was not necessarly visible, as the build process of FLTK didn't bail out with an error when it was failing. This if fixed by fltk-1.1.7-bail-out-on-error.patch. Finally, there was a problem with the tests of FLTK, so we disabled them. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/fltk/fltk-1.1.7-bail-out-on-error.patch')
-rw-r--r--package/fltk/fltk-1.1.7-bail-out-on-error.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/package/fltk/fltk-1.1.7-bail-out-on-error.patch b/package/fltk/fltk-1.1.7-bail-out-on-error.patch
new file mode 100644
index 000000000..644a0560b
--- /dev/null
+++ b/package/fltk/fltk-1.1.7-bail-out-on-error.patch
@@ -0,0 +1,54 @@
+When a submake fails, the build of FLTK was stopping, but the main
+make was returning 0. Therefore, Buildroot was going on with the build
+of the other components, even though the build of FLTK failed.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: fltk-1.1.7/Makefile
+===================================================================
+--- fltk-1.1.7.orig/Makefile 2010-05-21 15:52:20.000000000 +0200
++++ fltk-1.1.7/Makefile 2010-05-21 15:52:43.000000000 +0200
+@@ -32,7 +32,7 @@
+ all: makeinclude
+ for dir in $(DIRS); do\
+ echo "=== making $$dir ===";\
+- (cd $$dir; $(MAKE) $(MFLAGS)) || break;\
++ (cd $$dir; $(MAKE) $(MFLAGS)) || exit 1;\
+ done
+
+ install: makeinclude
+@@ -42,7 +42,7 @@
+ -chmod 755 $(DESTDIR)$(bindir)/fltk-config
+ for dir in FL $(DIRS); do\
+ echo "=== installing $$dir ===";\
+- (cd $$dir; $(MAKE) $(MFLAGS) install) || break;\
++ (cd $$dir; $(MAKE) $(MFLAGS) install) || exit 1;\
+ done
+
+ install-desktop: makeinclude
+@@ -54,7 +54,7 @@
+ $(RM) $(DESTDIR)$(bindir)/fltk-config
+ for dir in FL $(DIRS); do\
+ echo "=== uninstalling $$dir ===";\
+- (cd $$dir; $(MAKE) $(MFLAGS) uninstall) || break;\
++ (cd $$dir; $(MAKE) $(MFLAGS) uninstall) || exit 1;\
+ done
+
+ uninstall-desktop: makeinclude
+@@ -65,14 +65,14 @@
+ depend: makeinclude
+ for dir in $(DIRS); do\
+ echo "=== making dependencies in $$dir ===";\
+- (cd $$dir; $(MAKE) $(MFLAGS) depend) || break;\
++ (cd $$dir; $(MAKE) $(MFLAGS) depend) || exit 1;\
+ done
+
+ clean:
+ -$(RM) core *.o
+ for dir in $(DIRS); do\
+ echo "=== cleaning $$dir ===";\
+- (cd $$dir; $(MAKE) $(MFLAGS) clean) || break;\
++ (cd $$dir; $(MAKE) $(MFLAGS) clean) || exit 1;\
+ done
+
+ distclean: clean