summaryrefslogtreecommitdiffstats
path: root/package/flot
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-12-19 00:01:43 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-19 00:01:43 +0100
commita8342a525bb2287846d1dcfd279e54b1bfc2d3db (patch)
treec32df1a20959b67ed86c6850ad24755c35924bce /package/flot
parent645ff758fea4c640d1afc8d1a00da1a5f0b076ab (diff)
downloadbuildroot-novena-a8342a525bb2287846d1dcfd279e54b1bfc2d3db.tar.gz
buildroot-novena-a8342a525bb2287846d1dcfd279e54b1bfc2d3db.zip
package: add flot jQuery plugin
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/flot')
-rw-r--r--package/flot/Config.in59
-rw-r--r--package/flot/flot.mk23
2 files changed, 82 insertions, 0 deletions
diff --git a/package/flot/Config.in b/package/flot/Config.in
new file mode 100644
index 000000000..60534c1da
--- /dev/null
+++ b/package/flot/Config.in
@@ -0,0 +1,59 @@
+config BR2_PACKAGE_FLOT
+ bool "flot"
+ select BR2_PACKAGE_JQUERY
+ help
+ Flot is a pure Javascript plotting library for jQuery. It
+ produces graphical plots of arbitrary datasets on-the-fly
+ client-side.
+
+ The focus is on simple usage (all settings are optional),
+ attractive looks and interactive features like zooming and
+ mouse tracking.
+
+ The plugin works with Internet Explorer 6+, Firefox 2.x+,
+ Safari 3.0+, Opera 9.5+ and Konqueror 4.x+ with the HTML
+ canvas tag.
+
+ https://code.google.com/p/flot/
+
+if BR2_PACKAGE_FLOT
+
+comment "flot plugins"
+
+config BR2_PACKAGE_FLOT_NAVIGATE
+ bool "navigate"
+ help
+ Flot plugin for adding panning and zooming capabilities to a plot
+
+config BR2_PACKAGE_FLOT_PIE
+ bool "pie"
+ help
+ Flot plugin for rendering pie charts
+
+config BR2_PACKAGE_FLOT_RESIZE
+ bool "resize"
+ help
+ Flot plugin for automatically redrawing plots when the
+ placeholder size changes.
+
+config BR2_PACKAGE_FLOT_SELECTION
+ bool "selection"
+ help
+ Flot plugin for selecting regions
+
+config BR2_PACKAGE_FLOT_STACK
+ bool "stack"
+ help
+ Flot plugin for stacking data sets
+
+config BR2_PACKAGE_FLOT_SYMBOL
+ bool "symbol"
+ help
+ Flot plugin that adds some extra symbols for plotting points
+
+config BR2_PACKAGE_FLOT_THRESHOLD
+ bool "threshold"
+ help
+ Flot plugin for thresholding data
+
+endif
diff --git a/package/flot/flot.mk b/package/flot/flot.mk
new file mode 100644
index 000000000..df3f4d18a
--- /dev/null
+++ b/package/flot/flot.mk
@@ -0,0 +1,23 @@
+FLOT_VERSION = 0.7
+FLOT_SITE = http://flot.googlecode.com/files
+FLOT_FILES = jquery.flot $(addprefix jquery.flot.,\
+ $(if $(BR2_PACKAGE_FLOT_NAVIGATE),navigate) \
+ $(if $(BR2_PACKAGE_FLOT_PIE),pie) \
+ $(if $(BR2_PACKAGE_FLOT_RESIZE),resize) \
+ $(if $(BR2_PACKAGE_FLOT_SELECTION),selection) \
+ $(if $(BR2_PACKAGE_FLOT_STACK),stack) \
+ $(if $(BR2_PACKAGE_FLOT_SYMBOL),symbol) \
+ $(if $(BR2_PACKAGE_FLOT_THRESHOLD),threshold) \
+ )
+
+define FLOT_INSTALL_TARGET_CMDS
+ for i in $(FLOT_FILES); do \
+ $(INSTALL) -D $(@D)/$$i.min.js $(TARGET_DIR)/var/www/$$i.js; \
+ done
+endef
+
+define FLOT_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/var/www/jquery.flot*
+endef
+
+$(eval $(call GENTARGETS))