summaryrefslogtreecommitdiffstats
path: root/package/flex
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-05-26 12:08:17 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-27 23:51:38 +0200
commitfe6a9e5e9d4046173a60235f8fd9a3b4746929c6 (patch)
tree6f267daddabde4cab00532179e98e1a9b113c74e /package/flex
parentf8a9c13252fb1034b74ca88ff0716678d5914c75 (diff)
downloadbuildroot-novena-fe6a9e5e9d4046173a60235f8fd9a3b4746929c6.tar.gz
buildroot-novena-fe6a9e5e9d4046173a60235f8fd9a3b4746929c6.zip
flex: needs M4 at runtime
For proper runtime execution, flex requires m4 to be installed. Passing a M4 variable at configure time is needed, otherwise flex on the target will try to use a 'm4' binary with a build machine path. Fixes bug #4988. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/flex')
-rw-r--r--package/flex/Config.in2
-rw-r--r--package/flex/flex.mk1
2 files changed, 3 insertions, 0 deletions
diff --git a/package/flex/Config.in b/package/flex/Config.in
index f74a0f0e8..1ecd0c357 100644
--- a/package/flex/Config.in
+++ b/package/flex/Config.in
@@ -12,5 +12,7 @@ config BR2_PACKAGE_FLEX_BINARY
# needs fork()
depends on BR2_USE_MMU
depends on BR2_PACKAGE_FLEX
+ # runtime dependency
+ select BR2_PACKAGE_M4
help
Install the flex binary tool in the target filesystem.
diff --git a/package/flex/flex.mk b/package/flex/flex.mk
index f7e319f1c..748365b02 100644
--- a/package/flex/flex.mk
+++ b/package/flex/flex.mk
@@ -11,6 +11,7 @@ FLEX_LICENSE = FLEX
FLEX_LICENSE_FILES = COPYING
FLEX_DEPENDENCIES = \
$(if $(BR2_PACKAGE_GETTEXT_IF_LOCALE),gettext) host-m4
+FLEX_CONF_ENV = M4=/usr/bin/m4
# we don't have a host-gettext/libintl
HOST_FLEX_DEPENDENCIES = host-m4