summaryrefslogtreecommitdiffstats
path: root/package/findutils
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-10 21:50:22 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-13 16:55:46 +0200
commitc901bef2c80d9e2eac3ca482c40019957d8b3fe7 (patch)
treed556f5a75618de1c338a3675ce2ec7f1ad16e8f0 /package/findutils
parent9005b04bc0d854c3b896ffdfc56f6d6fcb417ec3 (diff)
downloadbuildroot-novena-c901bef2c80d9e2eac3ca482c40019957d8b3fe7.tar.gz
buildroot-novena-c901bef2c80d9e2eac3ca482c40019957d8b3fe7.zip
findutils: convert to the autotools infrastructure
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/findutils')
-rw-r--r--package/findutils/findutils.mk75
1 files changed, 1 insertions, 74 deletions
diff --git a/package/findutils/findutils.mk b/package/findutils/findutils.mk
index 96e2682a1..a1893ad56 100644
--- a/package/findutils/findutils.mk
+++ b/package/findutils/findutils.mk
@@ -5,79 +5,6 @@
#############################################################
FINDUTILS_VERSION:=4.2.31
FINDUTILS_SOURCE:=findutils-$(FINDUTILS_VERSION).tar.gz
-#FINDUTILS_SITE:=ftp://alpha.gnu.org/gnu/findutils
FINDUTILS_SITE:=$(BR2_GNU_MIRROR)/findutils/
-FINDUTILS_CAT:=$(ZCAT)
-FINDUTILS_DIR:=$(BUILD_DIR)/findutils-$(FINDUTILS_VERSION)
-FINDUTILS_BINARY:=find/find
-FINDUTILS_TARGET_BINARY:=usr/bin/find
-$(DL_DIR)/$(FINDUTILS_SOURCE):
- $(call DOWNLOAD,$(FINDUTILS_SITE),$(FINDUTILS_SOURCE))
-
-findutils-source: $(DL_DIR)/$(FINDUTILS_SOURCE)
-
-$(FINDUTILS_DIR)/.unpacked: $(DL_DIR)/$(FINDUTILS_SOURCE)
- $(FINDUTILS_CAT) $(DL_DIR)/$(FINDUTILS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- $(CONFIG_UPDATE) $(FINDUTILS_DIR)
- touch $@
-
-$(FINDUTILS_DIR)/.configured: $(FINDUTILS_DIR)/.unpacked
- (cd $(FINDUTILS_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- $(TARGET_CONFIGURE_ARGS) \
- ac_cv_func_setvbuf_reversed=no \
- ./configure $(QUIET) \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libdir=/lib \
- --libexecdir=/usr/lib/locate \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var/lib \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- )
- touch $@
-
-$(FINDUTILS_DIR)/$(FINDUTILS_BINARY): $(FINDUTILS_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(FINDUTILS_DIR)
-
-# This stuff is needed to work around GNU make deficiencies
-findutils-target_binary: $(FINDUTILS_DIR)/$(FINDUTILS_BINARY)
- @if [ -L $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY) ]; then \
- rm -f $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY); \
- fi
- @if [ ! -f $(FINDUTILS_DIR)/$(FINDUTILS_BINARY) \
- -o $(TARGET_DIR)/$(FINDUTILS_TARGET_BINARY) \
- -ot $(FINDUTILS_DIR)/$(FINDUTILS_BINARY) ]; then \
- set -x; \
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(FINDUTILS_DIR) install-strip; \
- $(STRIPCMD) $(TARGET_DIR)/usr/lib/locate/* > /dev/null 2>&1; \
- fi
- rm -rf $(TARGET_DIR)/share/locale
-
-findutils: findutils-target_binary
-
-findutils-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(FINDUTILS_DIR) uninstall
- -$(MAKE) -C $(FINDUTILS_DIR) clean
-
-findutils-dirclean:
- rm -rf $(FINDUTILS_DIR)
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_FINDUTILS),y)
-TARGETS+=findutils
-endif
+$(eval $(call AUTOTARGETS,package,findutils))