summaryrefslogtreecommitdiffstats
path: root/package/file
diff options
context:
space:
mode:
authorMichael Roth <mroth@nessie.de>2009-09-23 01:30:00 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-09-23 09:15:27 +0200
commitcb5710c538fce01f4875a64e6de4b37a7718005b (patch)
treec1ebe4a0dbbbe4c5a24f7cc765854b90e3a585df /package/file
parentbe695dcc3c9afd6836b90151301b6322de5dfcd8 (diff)
downloadbuildroot-novena-cb5710c538fce01f4875a64e6de4b37a7718005b.tar.gz
buildroot-novena-cb5710c538fce01f4875a64e6de4b37a7718005b.zip
rename TOOL_BUILD_DIR to TOOLCHAIN_DIR
To reflect the new output directory hierachy rename the Makefile variable TOOL_BUILD_DIR to TOOLCHAIN_DIR. Signed-off-by: Michael Roth <mroth@nessie.de> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/file')
-rw-r--r--package/file/file.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/file/file.mk b/package/file/file.mk
index fd04d20a8..1318ba802 100644
--- a/package/file/file.mk
+++ b/package/file/file.mk
@@ -7,7 +7,7 @@ FILE_VERSION:=4.26
FILE_SOURCE:=file-$(FILE_VERSION).tar.gz
FILE_SITE:=ftp://ftp.astron.com/pub/file/
FILE_SOURCE_DIR:=$(BUILD_DIR)/file-$(FILE_VERSION)
-FILE_DIR1:=$(TOOL_BUILD_DIR)/file-$(FILE_VERSION)-host
+FILE_DIR1:=$(TOOLCHAIN_DIR)/file-$(FILE_VERSION)-host
FILE_DIR2:=$(BUILD_DIR)/file-$(FILE_VERSION)-target
FILE_CAT:=$(ZCAT)
FILE_BINARY:=src/file
@@ -33,11 +33,11 @@ $(FILE_DIR1)/.configured: $(FILE_SOURCE_DIR)/.unpacked
)
touch $@
-$(TOOL_BUILD_DIR)/bin/file: $(FILE_DIR1)/.configured
+$(TOOLCHAIN_DIR)/bin/file: $(FILE_DIR1)/.configured
$(MAKE) -C $(FILE_DIR1) install
- ln -sf $(FILE_DIR1)/install/bin/file $(TOOL_BUILD_DIR)/bin/file
+ ln -sf $(FILE_DIR1)/install/bin/file $(TOOLCHAIN_DIR)/bin/file
-host-file: $(TOOL_BUILD_DIR)/bin/file
+host-file: $(TOOLCHAIN_DIR)/bin/file
host-file-clean:
-$(MAKE) -C $(FILE_DIR1) clean
@@ -84,7 +84,7 @@ $(FILE_DIR2)/.configured: $(FILE_SOURCE_DIR)/.unpacked
)
touch $@
-$(FILE_DIR2)/$(FILE_BINARY): $(FILE_DIR2)/.configured $(TOOL_BUILD_DIR)/bin/file
+$(FILE_DIR2)/$(FILE_BINARY): $(FILE_DIR2)/.configured $(TOOLCHAIN_DIR)/bin/file
ln -sf $(FILE_DIR1)/install/bin/file $(FILE_DIR2)/magic/file
$(MAKE) $(TARGET_CONFIGURE_OPTS) LDFLAGS="-static" -C $(FILE_DIR2)