summaryrefslogtreecommitdiffstats
path: root/package/fbgrab/fbgrab-proper-Makefile-for-cross-compiling.patch
diff options
context:
space:
mode:
authorgilles.talis@gmail.com <gilles.talis@gmail.com>2013-07-03 17:34:35 -0700
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-04 11:52:42 +0200
commit8916f9d80eb2c6a089ba4c9250656f47b5d6de77 (patch)
tree66a163f3da18c9c8d2737b2aed1f094cbc3ba8a0 /package/fbgrab/fbgrab-proper-Makefile-for-cross-compiling.patch
parent7f5177d3fdb2a3401c390e7ad69db373a5823c37 (diff)
downloadbuildroot-novena-8916f9d80eb2c6a089ba4c9250656f47b5d6de77.tar.gz
buildroot-novena-8916f9d80eb2c6a089ba4c9250656f47b5d6de77.zip
fbgrab: bump to version 1.1
[Peter: also update URL in Config.in] Signed-off-by: Gilles Talis <gilles.talis@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/fbgrab/fbgrab-proper-Makefile-for-cross-compiling.patch')
-rw-r--r--package/fbgrab/fbgrab-proper-Makefile-for-cross-compiling.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/package/fbgrab/fbgrab-proper-Makefile-for-cross-compiling.patch b/package/fbgrab/fbgrab-proper-Makefile-for-cross-compiling.patch
new file mode 100644
index 000000000..a211774db
--- /dev/null
+++ b/package/fbgrab/fbgrab-proper-Makefile-for-cross-compiling.patch
@@ -0,0 +1,39 @@
+From 2283817b9aed0b6228d0255d5aba7968379c9854 Mon Sep 17 00:00:00 2001
+From: Gilles Talis <gilles.talis@gmail.com>
+Date: Wed, 3 Jul 2013 11:40:36 -0700
+Subject: [PATCH] fbgrab: A proper Makefile for cross compiling
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Respect to the CC, CFLAGS and LDFLAGS is required for cross compiling in
+Buildroot. And there's no need to run the source through splint.
+
+Reworked original patch from: Daniel Nyström <daniel.nystrom@timeterminal.se>
+
+Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se>
+Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
+---
+ Makefile | 6 ++++--
+ 1 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index aae16e6..2d6b6fc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,8 +3,10 @@
+ ### modular. So this is a simple gnu Makefile...
+ ###
+
+-fbgrab: fbgrab.c
+- gcc -g -Wall fbgrab.c -lpng -lz -o fbgrab
++LDFLAGS += -lpng -lz
++
++fbgrab: fbgrab.o
++ $(CC) $(LDFLAGS) fbgrab.o -o $@
+
+ install:
+ install fbgrab /usr/bin/fbgrab
+--
+1.7.4.1
+