summaryrefslogtreecommitdiffstats
path: root/package/fbdump
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-08-27 11:01:16 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-08-27 11:01:16 +0000
commitf10aecd134cf82a20540fd31fc742add167e6167 (patch)
treea91cf89a2b69d6ff87d1fc9ba8fbfdc948f037b1 /package/fbdump
parentdc8423d97fc3579d6dde77198362225f377a200f (diff)
downloadbuildroot-novena-f10aecd134cf82a20540fd31fc742add167e6167.tar.gz
buildroot-novena-f10aecd134cf82a20540fd31fc742add167e6167.zip
fbdump: Add new package fbdump.
fbdump is a simple tool to capture snapshots from the Linux kernel framebuffer device and write them out as a PPM file. Currently, most packed-pixel framebuffer formats and the vga16 framebuffer are supported.
Diffstat (limited to 'package/fbdump')
-rw-r--r--package/fbdump/Config.in7
-rw-r--r--package/fbdump/fbdump.mk16
2 files changed, 23 insertions, 0 deletions
diff --git a/package/fbdump/Config.in b/package/fbdump/Config.in
new file mode 100644
index 000000000..2f3a2766e
--- /dev/null
+++ b/package/fbdump/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_FBDUMP
+ bool "fbdump (Framebuffer Capture Tool)"
+ help
+ fbdump is a simple tool to capture snapshots from the Linux kernel framebuffer
+ device and write them out as a PPM file. Currently, most packed-pixel framebuffer
+ formats and the vga16 framebuffer are supported.
+
diff --git a/package/fbdump/fbdump.mk b/package/fbdump/fbdump.mk
new file mode 100644
index 000000000..5ebfd7e12
--- /dev/null
+++ b/package/fbdump/fbdump.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# fbdump
+#
+#############################################################
+FBDUMP_VERSION:=0.4.2
+FBDUMP_SOURCE:=fbdump-$(FBDUMP_VERSION).tar.gz
+FBDUMP_SITE:=http://www.rcdrummond.net/fbdump
+FBDUMP_AUTORECONF = NO
+FBDUMP_CONF_ENV = ac_cv_func_malloc_0_nonnull=yes
+FBDUMP_INSTALL_STAGING = YES
+FBDUMP_INSTALL_TARGET = YES
+FBDUMP_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-strip
+
+$(eval $(call AUTOTARGETS,package,fbdump))
+