summaryrefslogtreecommitdiffstats
path: root/package/fakeroot
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-05-22 13:56:08 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-05-22 15:54:34 +0200
commit75c0a454887cb650f6fc049c8d12848a7cc6f3cc (patch)
tree0c3752a57898c6a910777da649dcce3924e2e43e /package/fakeroot
parent5c8c02a0c6747357ecc3f4884b065cf08bf2395a (diff)
downloadbuildroot-novena-75c0a454887cb650f6fc049c8d12848a7cc6f3cc.tar.gz
buildroot-novena-75c0a454887cb650f6fc049c8d12848a7cc6f3cc.zip
fakeroot: disallow selection for the target
fakeroot for the target fails to build against glibc, due to largefile related problems : libtool: link: /home/test/outputs/test-503/host/usr/bin/powerpc-linux-gnu-gcc -pipe -Os -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o faked faked.o ./.libs/libcommunicate.a -ldl {standard input}: Assembler messages: {standard input}:2592: Error: symbol `__fxstatat64' is already defined {standard input}:2627: Error: symbol `__fxstat64' is already defined {standard input}:2663: Error: symbol `__xstat64' is already defined {standard input}:2698: Error: symbol `__lxstat64' is already defined make[3]: *** [libfakeroot.lo] Error 1 As fakeroot for the target is not really needed, and was only added when we packaged fakeroot for the host, just make fakeroot not selectable for the target. We have to keep the AUTOTARGETS call for fakeroot on the target, because the host variant does not work otherwise, due to issues in the package infrastructure (that will be fixed post-2011.05). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/fakeroot')
-rw-r--r--package/fakeroot/Config.in6
-rw-r--r--package/fakeroot/fakeroot.mk3
2 files changed, 3 insertions, 6 deletions
diff --git a/package/fakeroot/Config.in b/package/fakeroot/Config.in
deleted file mode 100644
index 186b717d4..000000000
--- a/package/fakeroot/Config.in
+++ /dev/null
@@ -1,6 +0,0 @@
-config BR2_PACKAGE_FAKEROOT
- bool "fakeroot"
- help
- Run commands in an environment faking root privileges.
-
- http://joostje.op.het.net/fakeroot/
diff --git a/package/fakeroot/fakeroot.mk b/package/fakeroot/fakeroot.mk
index 8061443d7..29e9e5beb 100644
--- a/package/fakeroot/fakeroot.mk
+++ b/package/fakeroot/fakeroot.mk
@@ -16,5 +16,8 @@ endef
FAKEROOT_POST_PATCH_HOOKS += FAKEROOT_PATCH_FAKEROOT_IN
+# The package for the target cannot be selected (build problems when
+# largefile is enabled), but is needed for the host package to work
+# due to deficiencies in the package infrastructure.
$(eval $(call AUTOTARGETS,package,fakeroot))
$(eval $(call AUTOTARGETS,package,fakeroot,host))