summaryrefslogtreecommitdiffstats
path: root/package/ezxml
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-26 14:34:43 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-26 14:34:43 +0200
commit1114b4777495fdc2cd7dbe9397a4b8c07b399d41 (patch)
tree8f088fd2c28579f762636802e57447794620c0b9 /package/ezxml
parent5d132c1a81598f580d27d6e37571b9263698900d (diff)
downloadbuildroot-novena-1114b4777495fdc2cd7dbe9397a4b8c07b399d41.tar.gz
buildroot-novena-1114b4777495fdc2cd7dbe9397a4b8c07b399d41.zip
ezxml: misc fixes
Install into target as well, and use install -D instead of cp, to handle missing usr/include / usr/lib. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ezxml')
-rw-r--r--package/ezxml/ezxml.mk19
1 files changed, 17 insertions, 2 deletions
diff --git a/package/ezxml/ezxml.mk b/package/ezxml/ezxml.mk
index e29a7b522..58d262496 100644
--- a/package/ezxml/ezxml.mk
+++ b/package/ezxml/ezxml.mk
@@ -14,8 +14,23 @@ define EZXML_BUILD_CMDS
endef
define EZXML_INSTALL_STAGING_CMDS
- cp $(@D)/ezxml.h $(STAGING_DIR)/usr/include
- cp $(@D)/libezxml.a $(STAGING_DIR)/usr/lib
+ install -D -m 0644 $(@D)/ezxml.h $(STAGING_DIR)/usr/include/ezxml.h
+ install -D -m 0644 $(@D)/libezxml.a $(STAGING_DIR)/usr/lib/libezxml.a
+endef
+
+define EZXML_INSTALL_TARGET_CMDS
+ install -D -m 0644 $(@D)/ezxml.h $(TARGET_DIR)/usr/include/ezxml.h
+ install -D -m 0644 $(@D)/libezxml.a $(TARGET_DIR)/usr/lib/libezxml.a
+endef
+
+define EZXML_UNINSTALL_STAGING_CMDS
+ rm -f $(STAGING_DIR)/usr/include/ezxml.h
+ rm -f $(STAGING_DIR)/usr/lib/libezxml.a
+endef
+
+define EZXML_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/include/ezxml.h
+ rm -f $(TARGET_DIR)/usr/lib/libezxml.a
endef
define EZXML_CLEAN_CMDS