summaryrefslogtreecommitdiffstats
path: root/package/expat
diff options
context:
space:
mode:
authorMartin Banky <martin.banky@gmail.com>2010-10-09 12:52:50 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-10-14 07:27:10 -0400
commitfe26a7f0f2bb68c08509887d9b113e3c03e870ef (patch)
tree670845e018a943f808e5c36bcd7bcd4618946e92 /package/expat
parent83af822f7b28169b096d592027e97c55cc83eb27 (diff)
downloadbuildroot-novena-fe26a7f0f2bb68c08509887d9b113e3c03e870ef.tar.gz
buildroot-novena-fe26a7f0f2bb68c08509887d9b113e3c03e870ef.zip
Removed expat-libdir-la.patch
Now that expat.mk has been converted to autotools infrastructure, the patch is no longer needed. Autotools will automatically apply the needed patch. Signed-off-by: Martin Banky <Martin.Banky@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/expat')
-rw-r--r--package/expat/expat-libdir-la.patch77
-rw-r--r--package/expat/expat.mk1
2 files changed, 0 insertions, 78 deletions
diff --git a/package/expat/expat-libdir-la.patch b/package/expat/expat-libdir-la.patch
deleted file mode 100644
index 1c8930ea6..000000000
--- a/package/expat/expat-libdir-la.patch
+++ /dev/null
@@ -1,77 +0,0 @@
---- expat-2.0.0/conftools/ltmain.sh.orig 2007-01-13 14:39:51.000000000 -0700
-+++ expat-2.0.0/conftools/ltmain.sh 2007-01-13 14:39:56.000000000 -0700
-@@ -273,8 +273,9 @@
- # line option must be used.
- if test -z "$tagname"; then
- $echo "$modename: unable to infer tagged configuration"
-- $echo "$modename: specify a tag with \`--tag'" 1>&2
-- exit $EXIT_FAILURE
-+ $echo "$modename: defaulting to \`CC'"
-+ $echo "$modename: if this is not correct, specify a tag with \`--tag'"
-+# exit $EXIT_FAILURE
- # else
- # $echo "$modename: using $tagname tagged configuration"
- fi
-@@ -2404,8 +2405,14 @@
- absdir="$abs_ladir"
- libdir="$abs_ladir"
- else
-- dir="$libdir"
-- absdir="$libdir"
-+ # Adding 'libdir' from the .la file to our library search paths
-+ # breaks crosscompilation horribly. We cheat here and don't add
-+ # it, instead adding the path where we found the .la. -CL
-+ dir="$abs_ladir"
-+ absdir="$abs_ladir"
-+ libdir="$abs_ladir"
-+ #dir="$libdir"
-+ #absdir="$libdir"
- fi
- test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes
- else
-@@ -2886,6 +2893,16 @@
- esac
- if grep "^installed=no" $deplib > /dev/null; then
- path="$absdir/$objdir"
-+# This interferes with crosscompilation. -CL
-+# else
-+# eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
-+# if test -z "$libdir"; then
-+# $echo "$modename: \`$deplib' is not a valid libtool archive" 1>&2
-+# exit 1
-+# fi
-+# if test "$absdir" != "$libdir"; then
-+# $echo "$modename: warning: \`$deplib' seems to be moved" 1>&2
-+# fi
- else
- eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
- if test -z "$libdir"; then
-@@ -5598,6 +5615,10 @@
- # Replace all uninstalled libtool libraries with the installed ones
- newdependency_libs=
- for deplib in $dependency_libs; do
-+ # Replacing uninstalled with installed can easily break crosscompilation,
-+ # since the installed path is generally the wrong architecture. -CL
-+ newdependency_libs="$newdependency_libs $deplib"
-+ continue
- case $deplib in
- *.la)
- name=`$echo "X$deplib" | $Xsed -e 's%^.*/%%'`
-@@ -5919,10 +5940,13 @@
- # At present, this check doesn't affect windows .dll's that
- # are installed into $libdir/../bin (currently, that works fine)
- # but it's something to keep an eye on.
-- if test "$inst_prefix_dir" = "$destdir"; then
-- $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
-- exit $EXIT_FAILURE
-- fi
-+ #
-+ # This breaks install into our staging area. -PB
-+ #
-+ # if test "$inst_prefix_dir" = "$destdir"; then
-+ # $echo "$modename: error: cannot install \`$file' to a directory not ending in $libdir" 1>&2
-+ # exit $EXIT_FAILURE
-+ # fi
-
- if test -n "$inst_prefix_dir"; then
- # Stick the inst_prefix_dir data into the link command.
diff --git a/package/expat/expat.mk b/package/expat/expat.mk
index f82a904e0..03b13037e 100644
--- a/package/expat/expat.mk
+++ b/package/expat/expat.mk
@@ -7,7 +7,6 @@
EXPAT_VERSION = 2.0.1
EXPAT_SOURCE = expat-$(EXPAT_VERSION).tar.gz
EXPAT_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/expat
-EXPAT_LIBTOOL_PATCH = NO
EXPAT_INSTALL_STAGING = YES
EXPAT_INSTALL_TARGET = YES
EXPAT_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) installlib