summaryrefslogtreecommitdiffstats
path: root/package/expat/expat.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/expat/expat.mk
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/expat/expat.mk')
-rw-r--r--package/expat/expat.mk14
1 files changed, 8 insertions, 6 deletions
diff --git a/package/expat/expat.mk b/package/expat/expat.mk
index d14d3674f..82708978c 100644
--- a/package/expat/expat.mk
+++ b/package/expat/expat.mk
@@ -29,13 +29,15 @@ $(EXPAT_DIR)/.configured: $(EXPAT_DIR)/.unpacked
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
- --bindir=$(STAGING_DIR)/usr/bin \
- --sbindir=$(STAGING_DIR)/usr/sbin \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
- --mandir=$(STAGING_DIR)/man \
+ --includedir=/include \
+ --mandir=/usr/man \
--infodir=/usr/info \
--enable-shared \
);
@@ -46,8 +48,8 @@ $(EXPAT_DIR)/.libs/libexpat.a: $(EXPAT_DIR)/.configured
touch -c $(EXPAT_DIR)/.libs/libexpat.a
$(STAGING_DIR)/lib/libexpat.so.1: $(EXPAT_DIR)/.libs/libexpat.a
- $(MAKE) -C $(EXPAT_DIR) prefix=$(STAGING_DIR) \
- exec_prefix=$(STAGING_DIR) mandir=$(STAGING_DIR)/man install
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(EXPAT_DIR) install
+ $(SED) "s,^libdir=.*,libdir=\'$(STAGING_DIR)/lib\',g" $(STAGING_DIR)/lib/libexpat.la
touch -c $(STAGING_DIR)/lib/libexpat.so.1
$(TARGET_DIR)/lib/libexpat.so.1: $(STAGING_DIR)/lib/libexpat.so.1
@@ -56,7 +58,7 @@ $(TARGET_DIR)/lib/libexpat.so.1: $(STAGING_DIR)/lib/libexpat.so.1
-$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libexpat.so.0.5.0
touch -c $(TARGET_DIR)/lib/libexpat.so.1
-expat: uclibc $(TARGET_DIR)/lib/libexpat.so.1
+expat: uclibc pkgconfig $(TARGET_DIR)/lib/libexpat.so.1
expat-clean:
rm -f $(EXPAT_DIR)/.configured