summaryrefslogtreecommitdiffstats
path: root/package/evtest
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-09-28 12:04:49 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-28 22:08:39 +0200
commit7d1473859dab0be549eadb605cfe492f72494fbb (patch)
tree539f2dd44e59f08b1fc72bf33dbee77c087434af /package/evtest
parent3d0c79aa9fa7635fdc91f889c6fa160aecd3d576 (diff)
downloadbuildroot-novena-7d1473859dab0be549eadb605cfe492f72494fbb.tar.gz
buildroot-novena-7d1473859dab0be549eadb605cfe492f72494fbb.zip
evtest: add as a seperate package
Evtest is nowadays maintained as a seperate package by Peter Hutterer. The project doesn't release any tarballs, so use the one of Fedora instead so we don't need to autoreconf: http://comments.gmane.org/gmane.comp.freedesktop.xorg.announce/1671 Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/evtest')
-rw-r--r--package/evtest/Config.in18
-rw-r--r--package/evtest/evtest.mk28
2 files changed, 46 insertions, 0 deletions
diff --git a/package/evtest/Config.in b/package/evtest/Config.in
new file mode 100644
index 000000000..e8f9e3736
--- /dev/null
+++ b/package/evtest/Config.in
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_EVTEST
+ bool "evtest"
+ help
+ evtest displays information on the input device specified on
+ the command line, including all the events supported by the
+ device. It then monitors the device and displays all the
+ events layer events generated.
+
+ http://www.freedesktop.org/wiki/Evtest
+
+config BR2_PACKAGE_EVTEST_CAPTURE
+ bool "evtest-capture"
+ depends on BR2_PACKAGE_EVTEST
+ select BR2_PACKAGE_LIBXML2
+ help
+ evtest-capture captures the information and events from the
+ input device specified on the command line and writes it to
+ the xml file given.
diff --git a/package/evtest/evtest.mk b/package/evtest/evtest.mk
new file mode 100644
index 000000000..582d1a71e
--- /dev/null
+++ b/package/evtest/evtest.mk
@@ -0,0 +1,28 @@
+#############################################################
+#
+# evtest
+#
+#############################################################
+
+EVTEST_VERSION = 1.30
+EVTEST_SOURCE = evtest-$(EVTEST_VERSION).tar.bz2
+# no official upstream tarball
+EVTEST_SITE = http://pkgs.fedoraproject.org/repo/pkgs/evtest/evtest-1.30.tar.bz2/27c0902839babfd07136f232c63c895c/
+EVTEST_LICENSE = GPLv2
+EVTEST_LICENSE_FILES = COPYING
+EVTEST_DEPENDENCIES = host-pkg-config
+
+ifeq ($(BR2_PACKAGE_EVTEST_CAPTURE),y)
+EVTEST_DEPENDENCIES += libxml2
+else
+# evtest-capture will unconditionally be built/installed if libxml2 is present
+define EVTEST_REMOVE_EVTEST_CAPTURE
+ rm -rf $(TARGET_DIR)/usr/bin/evtest-capture \
+ $(TARGET_DIR)/usr/share/evtest \
+ $(TARGET_DIR)/usr/share/man/man1/evtest-capture.1
+endef
+
+EVTEST_POST_INSTALL_TARGET_HOOKS += EVTEST_REMOVE_EVTEST_CAPTURE
+endif
+
+$(eval $(autotools-package))