summaryrefslogtreecommitdiffstats
path: root/package/enchant
diff options
context:
space:
mode:
authorWill Newton <will.newton@gmail.com>2009-08-07 17:06:32 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-08-07 19:00:40 +0200
commitda282970915ff9e6c6320afc9f40e99e17589028 (patch)
treea37aafe3dcd6651478421d248eddb45e78017dbe /package/enchant
parenta0c23b6d2b5ef8222a98d426cb42f6aa2e47b228 (diff)
downloadbuildroot-novena-da282970915ff9e6c6320afc9f40e99e17589028.tar.gz
buildroot-novena-da282970915ff9e6c6320afc9f40e99e17589028.zip
enchant: Fix dependencies.
Enchant requires C++ support, libglib2 and pkg-config. Signed-off-by: Will Newton <will.newton@gmail.com>
Diffstat (limited to 'package/enchant')
-rw-r--r--package/enchant/Config.in2
-rw-r--r--package/enchant/enchant.mk2
2 files changed, 4 insertions, 0 deletions
diff --git a/package/enchant/Config.in b/package/enchant/Config.in
index 0771a47b9..e65d68116 100644
--- a/package/enchant/Config.in
+++ b/package/enchant/Config.in
@@ -1,5 +1,7 @@
config BR2_PACKAGE_ENCHANT
bool "enchant"
+ depends on BR2_INSTALL_LIBSTDCPP
+ select BR2_PACKAGE_LIBGLIB2
help
Enchant is a spell-checking library that provides a consistent
API across a number of spell-checking system backends.
diff --git a/package/enchant/enchant.mk b/package/enchant/enchant.mk
index d97246515..63cd311c6 100644
--- a/package/enchant/enchant.mk
+++ b/package/enchant/enchant.mk
@@ -11,4 +11,6 @@ ENCHANT_INSTALL_STAGING = YES
ENCHANT_INSTALL_TARGET = YES
ENCHANT_LIBTOOL_PATCH = NO
+ENCHANT_DEPENDENCIES = libglib2 host-pkgconfig
+
$(eval $(call AUTOTARGETS,package,enchant))