summaryrefslogtreecommitdiffstats
path: root/package/elfutils/elfutils.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-01-06 05:22:44 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-07 21:37:52 +0100
commit871846cad435ba3331a9f57c8939889ec86df887 (patch)
tree39b9534733d4e462e953e4ebe1eda76f80bb3c7d /package/elfutils/elfutils.mk
parent75bd7d13b2a772786df2b77be9af91ddda450174 (diff)
downloadbuildroot-novena-871846cad435ba3331a9f57c8939889ec86df887.tar.gz
buildroot-novena-871846cad435ba3331a9f57c8939889ec86df887.zip
elfutils: make it possible to only install the libraries
Add and use a --{enable,disable}-progs configuration option to selectively enable or disable the elfutils programs. Generally, on an embedded system, the libraries are more useful than the programs, and being able to not build the programs will make it easier to build the elfutils libraries on uClibc. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/elfutils/elfutils.mk')
-rw-r--r--package/elfutils/elfutils.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/elfutils/elfutils.mk b/package/elfutils/elfutils.mk
index 27500606b..f8a4e85da 100644
--- a/package/elfutils/elfutils.mk
+++ b/package/elfutils/elfutils.mk
@@ -46,4 +46,10 @@ else
ELFUTILS_CONF_OPT += --without-lzma
endif
+ifeq ($(BR2_PACKAGE_ELFUTILS_PROGS),y)
+ ELFUTILS_CONF_OPT += --enable-progs
+else
+ ELFUTILS_CONF_OPT += --disable-progs
+endif
+
$(eval $(autotools-package))