summaryrefslogtreecommitdiffstats
path: root/package/efl
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-12-24 12:23:27 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-12-30 07:21:58 +0100
commit20e90e4f0d2628322b0f376043b29668806cf3d3 (patch)
tree51668f1202ad201acfe12baa1d4ff3abe7c8b92e /package/efl
parentfee5783d17b7e69132d63ba4fb1b660ec2c862e3 (diff)
downloadbuildroot-novena-20e90e4f0d2628322b0f376043b29668806cf3d3.tar.gz
buildroot-novena-20e90e4f0d2628322b0f376043b29668806cf3d3.zip
efl/libeio: new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/efl')
-rw-r--r--package/efl/Config.in1
-rw-r--r--package/efl/libeio/Config.in18
-rw-r--r--package/efl/libeio/libeio.mk16
3 files changed, 35 insertions, 0 deletions
diff --git a/package/efl/Config.in b/package/efl/Config.in
index c783d7f07..a526d87a4 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -13,6 +13,7 @@ source "package/efl/libeina/Config.in"
source "package/efl/libecore/Config.in"
source "package/efl/libeet/Config.in"
source "package/efl/libefreet/Config.in"
+source "package/efl/libeio/Config.in"
source "package/efl/libevas/Config.in"
source "package/efl/libembryo/Config.in"
source "package/efl/libedje/Config.in"
diff --git a/package/efl/libeio/Config.in b/package/efl/libeio/Config.in
new file mode 100644
index 000000000..0b2751ce6
--- /dev/null
+++ b/package/efl/libeio/Config.in
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_LIBEIO
+ bool "libeio"
+ select BR2_PACKAGE_LIBEET
+ select BR2_PACKAGE_LIBEINA
+ select BR2_PACKAGE_LIBECORE
+ help
+ Eio integrates with EFL (Ecore, Eina) to provide efficient
+ filesystem Input/Output (I/O). It use the best techniques to
+ achieve such purpose, like using at-variants, splice,
+ properly handling errors and doing it in an asynchronous
+ fashion by means of worker threads. It is also ported to
+ Windows, so multi-platform.
+
+ Whenever you need to list a directory, copy, move or delete
+ files, Eio will do that task better than you'd achieve with
+ naive implementations, and it is easy to use.
+
+ http://trac.enlightenment.org/e/wiki/Eio
diff --git a/package/efl/libeio/libeio.mk b/package/efl/libeio/libeio.mk
new file mode 100644
index 000000000..f5e08de5b
--- /dev/null
+++ b/package/efl/libeio/libeio.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# libeio
+#
+#############################################################
+
+LIBEIO_VERSION = 1.7.4
+LIBEIO_SOURCE = eio-$(LIBEIO_VERSION).tar.bz2
+LIBEIO_SITE = http://download.enlightenment.org/releases/
+LIBEIO_LICENSE = LGPLv2.1
+LIBEIO_LICENSE_FILES = COPYING
+
+LIBEIO_INSTALL_STAGING = YES
+LIBEIO_DEPENDENCIES = libeina libeet libecore
+
+$(eval $(autotools-package))