summaryrefslogtreecommitdiffstats
path: root/package/efl/libevas
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-01-30 08:52:52 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-30 08:52:52 +0100
commita52db793e944d61947042eac6dc686577e82bd47 (patch)
treea75138b620b97e839fe09412e98269497a551699 /package/efl/libevas
parenta4e27b11607113f178366469c4c2a827941be283 (diff)
downloadbuildroot-novena-a52db793e944d61947042eac6dc686577e82bd47.tar.gz
buildroot-novena-a52db793e944d61947042eac6dc686577e82bd47.zip
libevas: forcibly disable cpu optimization options if not applicable
Otherwise the configure script will automatically enable them for potentially compatible targets. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/efl/libevas')
-rw-r--r--package/efl/libevas/libevas.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/efl/libevas/libevas.mk b/package/efl/libevas/libevas.mk
index 3a1e42d2e..6ad1126e7 100644
--- a/package/efl/libevas/libevas.mk
+++ b/package/efl/libevas/libevas.mk
@@ -103,19 +103,28 @@ LIBEVAS_CONF_OPT += --enable-cpu-sse
ifneq ($(BR2_x86_pentium3)$(BR2_x86_pentium4)$(BR2_x86_prescott)$(BR2_x86_athlon_4)$(BR2_x86_opteron)$(BR2_x86_c32)$(BR2_x86_64_opteron),y)
LIBEVAS_CONF_OPT += --enable-cpu-sse3
-
+else
+LIBEVAS_CONF_OPT += --disable-cpu-sse3
endif # sse3
+else
+LIBEVAS_CONF_OPT += --disable-cpu-sse
endif # sse
+else
+LIBEVAS_CONF_OPT += --disable-cpu-mmx
endif # mmx
endif # x86
ifeq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),y)
LIBEVAS_CONF_OPT += --enable-cpu-altivec
+else
+LIBEVAS_CONF_OPT += --disable-cpu-altivec
endif
ifeq ($(BR2_cortex_a8)$(BR2_cortex_a9),y)
# NEON is optional for A9
LIBEVAS_CONF_OPT += --enable-cpu-neon
+else
+LIBEVAS_CONF_OPT += --disable-cpu-neon
endif
# loaders