summaryrefslogtreecommitdiffstats
path: root/package/ebtables
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2011-07-11 17:33:31 +0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-11 23:11:55 +0200
commita8041c0973528f4ef15e1a67cc1d3baf08261b4f (patch)
treea6d63ca495f8fad995d6e0249a153dbe6e973616 /package/ebtables
parentfc71f7e6f27829a389dacc38622eb687109133f6 (diff)
downloadbuildroot-novena-a8041c0973528f4ef15e1a67cc1d3baf08261b4f.tar.gz
buildroot-novena-a8041c0973528f4ef15e1a67cc1d3baf08261b4f.zip
ebtables: new package
[Peter: add ipv6 dependency] Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ebtables')
-rw-r--r--package/ebtables/Config.in10
-rw-r--r--package/ebtables/ebtables.mk30
2 files changed, 40 insertions, 0 deletions
diff --git a/package/ebtables/Config.in b/package/ebtables/Config.in
new file mode 100644
index 000000000..40bc45c02
--- /dev/null
+++ b/package/ebtables/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_EBTABLES
+ bool "ebtables"
+ depends on BR2_INET_IPV6
+ help
+ Ethernet bridge frame table administration
+
+ http://ebtables.sourceforge.net
+
+comment "ebtables requires a toolchain with IPv6 support"
+ depends on !BR2_INET_IPV6
diff --git a/package/ebtables/ebtables.mk b/package/ebtables/ebtables.mk
new file mode 100644
index 000000000..67c0d9246
--- /dev/null
+++ b/package/ebtables/ebtables.mk
@@ -0,0 +1,30 @@
+#############################################################
+#
+# ebtables
+#
+#############################################################
+EBTABLES_VERSION = 2.0.10-1
+EBTABLES_SOURCE = ebtables-v$(EBTABLES_VERSION).tar.gz
+EBTABLES_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/ebtables
+
+define EBTABLES_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) LIBDIR=/lib/ebtables -C $(@D)
+endef
+
+define EBTABLES_INSTALL_TARGET_CMDS
+ for so in $(@D)/$(EBTABLES_SUBDIR)/*.so \
+ $(@D)/$(EBTABLES_SUBDIR)/extensions/*.so; \
+ do \
+ $(INSTALL) -m 0755 -D $${so} \
+ $(TARGET_DIR)/lib/ebtables/`basename $${so}`; \
+ done
+ $(INSTALL) -m 0755 -D $(@D)/$(EBTABLES_SUBDIR)/ebtables \
+ $(TARGET_DIR)/sbin/ebtables
+endef
+
+define EBTABLES_UNINSTALL_TARGET_CMDS
+ rm -rf $(TARGET_DIR)/lib/ebtables
+ rm -f $(TARGET_DIR)/sbin/ebtables
+endef
+
+$(eval $(call GENTARGETS,package,ebtables))