summaryrefslogtreecommitdiffstats
path: root/package/dvb-apps
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2012-12-28 11:48:34 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-28 23:27:12 +0100
commit5e0b900c72bce75a3f86306d0aae79e9655a4753 (patch)
tree91cc86d7f71ed581dbd6a9a88549153dcafbd310 /package/dvb-apps
parent653d64c5094d34ade03d0c30ead151ac9223edbd (diff)
downloadbuildroot-novena-5e0b900c72bce75a3f86306d0aae79e9655a4753.tar.gz
buildroot-novena-5e0b900c72bce75a3f86306d0aae79e9655a4753.zip
package/dvb-apps: new package
We just need the transponders data, so we just install those. [Peter: rework install step] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dvb-apps')
-rw-r--r--package/dvb-apps/dvb-apps.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/dvb-apps/dvb-apps.mk b/package/dvb-apps/dvb-apps.mk
new file mode 100644
index 000000000..721fbf0e0
--- /dev/null
+++ b/package/dvb-apps/dvb-apps.mk
@@ -0,0 +1,28 @@
+#############################################################
+#
+# dvb-apps
+#
+#############################################################
+
+DVB_APPS_VERSION = 3fc7dfa68484
+DVB_APPS_SOURCE = dvb-apps-$(DVB_APPS_VERSION).tar.bz2
+DVB_APPS_SITE = http://linuxtv.org/hg/dvb-apps/archive/
+
+# We just install the transponders data. As this is not a 'work' as per
+# traditional copyright, but just a collection of 'facts', there's probably
+# no license to apply to these data files.
+# To be noted however, is that the dvb-apps package bundles a copy of the
+# GPLv2 and a copy of the LGPLv2.1, and that some of the source files refer
+# to either the GPLv2+ or the LGPLv2.1+.
+# But since we do not use any of those source files, their license do not
+# apply to us.
+DVB_APPS_LICENSE = unknown (probably public domain)
+
+define DVB_APPS_INSTALL_TARGET_CMDS
+ for i in atsc dvb-c dvb-s dvb-t; do \
+ mkdir -p $(TARGET_DIR)/usr/share/dvb-apps/scan/$$i; \
+ $(INSTALL) $(@D)/util/scan/$$i/* $(TARGET_DIR)/usr/share/dvb-apps/scan/$$i; \
+ done
+endef
+
+$(eval $(generic-package))