summaryrefslogtreecommitdiffstats
path: root/package/dtc/dtc-separate-lib-install.patch
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-05-09 12:22:58 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-12 23:47:42 +0200
commit47f578e3c2db53caf51fad9ec24e71ff1606c862 (patch)
tree45c6d2a6a728e10740a0a4548582e40b5737c3b3 /package/dtc/dtc-separate-lib-install.patch
parent4ae47d82649d38de6896270a6b6945d2467b7047 (diff)
downloadbuildroot-novena-47f578e3c2db53caf51fad9ec24e71ff1606c862.tar.gz
buildroot-novena-47f578e3c2db53caf51fad9ec24e71ff1606c862.zip
package/dtc: new package
dtc is the Device Tree Compiler, and manipulates device trees. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dtc/dtc-separate-lib-install.patch')
-rw-r--r--package/dtc/dtc-separate-lib-install.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/dtc/dtc-separate-lib-install.patch b/package/dtc/dtc-separate-lib-install.patch
new file mode 100644
index 000000000..c86d587a1
--- /dev/null
+++ b/package/dtc/dtc-separate-lib-install.patch
@@ -0,0 +1,28 @@
+Makefile: add a rule to only install libfdt
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+
+---
+Patch not sent upstream.
+
+It's really specific to buildroot, and is probably not
+good (aka generic) enough to be pushed upstream.
+
+diff --git a/Makefile b/Makefile
+index 1169e6c..39e7190 100644
+--- a/Makefile
++++ b/Makefile
+@@ -160,10 +160,12 @@ endif
+ # intermediate target and building them again "for real"
+ .SECONDARY: $(DTC_GEN_SRCS) $(CONVERT_GEN_SRCS)
+
+-install: all $(SCRIPTS)
++install: all $(SCRIPTS) libfdt_install
+ @$(VECHO) INSTALL
+ $(INSTALL) -d $(DESTDIR)$(BINDIR)
+ $(INSTALL) $(BIN) $(SCRIPTS) $(DESTDIR)$(BINDIR)
++
++libfdt_install: libfdt
+ $(INSTALL) -d $(DESTDIR)$(LIBDIR)
+ $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
+ ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)