summaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-03-21 08:02:23 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-24 14:30:38 +0100
commit45934386505ccea444b9c5b84742a3504d75de02 (patch)
treee4e7aa5a05fd15b07a213a7018cc6545043f7d4a /package/dropbear
parent62322acb2ce186d544ab21fe253ccc8561a68a48 (diff)
downloadbuildroot-novena-45934386505ccea444b9c5b84742a3504d75de02.tar.gz
buildroot-novena-45934386505ccea444b9c5b84742a3504d75de02.zip
dropbear: bump to version 2013.56
Switch ECHOs to SEDs to avoid issues with defines changing after sysoptions.h was included - and it's cleaner. Enable hmac-sha2-256 and hmac-sha2-512 support for the full featured. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/dropbear.mk13
1 files changed, 8 insertions, 5 deletions
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
index bd4522189..cec57dbeb 100644
--- a/package/dropbear/dropbear.mk
+++ b/package/dropbear/dropbear.mk
@@ -4,8 +4,9 @@
#
#############################################################
-DROPBEAR_VERSION = 2012.55
+DROPBEAR_VERSION = 2013.56
DROPBEAR_SITE = http://matt.ucc.asn.au/dropbear/releases
+DROPBEAR_SOURCE = dropbear-$(DROPBEAR_VERSION).tar.bz2
DROPBEAR_TARGET_BINS = dbclient dropbearkey dropbearconvert scp ssh
DROPBEAR_MAKE = $(MAKE) MULTI=1 SCPPROGRESS=1 \
PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp"
@@ -24,16 +25,18 @@ endef
DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_FIX_XAUTH
define DROPBEAR_DISABLE_REVERSE_DNS
- $(SED) 's,^#define DO_HOST_LOOKUP.*,/* #define DO_HOST_LOOKUP */,' $(@D)/options.h
+ $(SED) 's:\(#define DO_HOST_LOOKUP\):/*\1 */:' $(@D)/options.h
endef
define DROPBEAR_BUILD_SMALL
- echo "#define DROPBEAR_SMALL_CODE" >>$(@D)/options.h
- echo "#define NO_FAST_EXPTMOD" >>$(@D)/options.h
+ $(SED) 's:.*\(#define DROPBEAR_SMALL_CODE\).*:\1:' $(@D)/options.h
+ $(SED) 's:.*\(#define NO_FAST_EXPTMOD\).*:\1:' $(@D)/options.h
endef
define DROPBEAR_BUILD_FEATURED
- echo "#define DROPBEAR_BLOWFISH" >>$(@D)/options.h
+ $(SED) 's:.*\(#define DROPBEAR_BLOWFISH\).*:\1:' $(@D)/options.h
+ $(SED) 's:.*\(#define DROPBEAR_SHA2_256_HMAC\).*:\1:' $(@D)/options.h
+ $(SED) 's:.*\(#define DROPBEAR_SHA2_512_HMAC\).*:\1:' $(@D)/options.h
endef
ifeq ($(BR2_PACKAGE_DROPBEAR_DISABLE_REVERSEDNS),y)