summaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
authorMarc Gauthier <marc@tensilica.com>2009-05-28 14:31:20 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-05-28 14:31:20 +0200
commit4088a5294dfd326b77cde77d12a7f97af89500ad (patch)
tree681aad55f7561c05804141b004ae3b96ef6b9281 /package/dropbear
parent77fad2fd74867d6d6bf77a52a1fc41379fa803c5 (diff)
downloadbuildroot-novena-4088a5294dfd326b77cde77d12a7f97af89500ad.tar.gz
buildroot-novena-4088a5294dfd326b77cde77d12a7f97af89500ad.zip
dropbear: fix initscript install
The -D option to install only works portably when the destination is a file. Specifying the filename avoids the following build error (at least on some hosts): "/usr/bin/install: cannot overwrite directory `/tmp/buildroot/ project_build_foobar/uclibc/root/etc/init.d' with non-directory" Signed-off-by: Marc Gauthier <marc@tensilica.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/dropbear.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
index e84df8758..63d3daaf1 100644
--- a/package/dropbear/dropbear.mk
+++ b/package/dropbear/dropbear.mk
@@ -28,7 +28,7 @@ $(DROPBEAR_TARGET_INSTALL_TARGET):
ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/scp
ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/ssh
if [ ! -f $(TARGET_DIR)/etc/init.d/S50dropbear ]; then \
- $(INSTALL) -m 0755 -D package/dropbear/S50dropbear $(TARGET_DIR)/etc/init.d; \
+ $(INSTALL) -m 0755 -D package/dropbear/S50dropbear $(TARGET_DIR)/etc/init.d/S50dropbear; \
fi
touch $@