summaryrefslogtreecommitdiffstats
path: root/package/dosfstools
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-21 15:50:18 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-23 20:34:55 +0100
commite83529882b71cb8a2c6ba2c997308196a2857af0 (patch)
tree556c3e7fb2c0629cbdb11132d3038f97aeb4021e /package/dosfstools
parent520dd9fbe5896175285a494aeeabe221bce9db62 (diff)
downloadbuildroot-novena-e83529882b71cb8a2c6ba2c997308196a2857af0.tar.gz
buildroot-novena-e83529882b71cb8a2c6ba2c997308196a2857af0.zip
dosfstools: make sure install targets aren't run everytime
Adding real targets to $(TARGETS) doesn't work, since they are prefixed __real_tgt by the main Makefile. 'make' then always thinks that these targets aren't up-to-date, and re-generate them every time. Therefore, we switch dosfstools to the more common way of handling packages, with a phony target added to $(TARGETS), this phony target depending on real targets. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/dosfstools')
-rw-r--r--package/dosfstools/dosfstools.mk32
1 files changed, 19 insertions, 13 deletions
diff --git a/package/dosfstools/dosfstools.mk b/package/dosfstools/dosfstools.mk
index e1e9fe34e..b826ab183 100644
--- a/package/dosfstools/dosfstools.mk
+++ b/package/dosfstools/dosfstools.mk
@@ -32,7 +32,8 @@ $(DOSFSTOOLS_DIR)/.built : $(DOSFSTOOLS_DIR)/.unpacked
$(STRIPCMD) $(DOSFSTOOLS_DIR)/$(DOSFSLABEL_BINARY)
touch $@
-$(TARGET_DIR)/$(MKDOSFS_TARGET_BINARY): $(DOSFSTOOLS_DIR)/.built
+$(TARGET_DIR)/$(MKDOSFS_TARGET_BINARY): # $(DOSFSTOOLS_DIR)/.built
+ echo foo
cp -a $(DOSFSTOOLS_DIR)/$(MKDOSFS_BINARY) $@
touch -c $@
@@ -44,7 +45,20 @@ $(TARGET_DIR)/$(DOSFSLABEL_TARGET_BINARY): $(DOSFSTOOLS_DIR)/.built
cp -a $(DOSFSTOOLS_DIR)/$(DOSFSLABEL_BINARY) $@
touch -c $@
-dosfstools: $(TARGET_DIR)/$(DOSFSTOOLS_TARGET_BINARY) $(TARGET_DIR)/$(DOSFSCK_TARGET_BINARY)
+DOSFSTOOLS=
+ifeq ($(BR2_PACKAGE_DOSFSTOOLS_MKDOSFS),y)
+DOSFSTOOLS+=$(TARGET_DIR)/$(MKDOSFS_TARGET_BINARY)
+endif
+
+ifeq ($(BR2_PACKAGE_DOSFSTOOLS_DOSFSCK),y)
+DOSFSTOOLS+=$(TARGET_DIR)/$(DOSFSCK_TARGET_BINARY)
+endif
+
+ifeq ($(BR2_PACKAGE_DOSFSTOOLS_DOSFSLABEL),y)
+DOSFSTOOLS+=$(TARGET_DIR)/$(DOSFSLABEL_TARGET_BINARY)
+endif
+
+dosfstools: $(DOSFSTOOLS)
dosfstools-clean:
rm -f $(TARGET_DIR)/$(MKDOSFS_TARGET_BINARY)
@@ -60,14 +74,6 @@ dosfstools-dirclean:
# Toplevel Makefile options
#
#############################################################
-ifeq ($(BR2_PACKAGE_DOSFSTOOLS_MKDOSFS),y)
-TARGETS+=$(TARGET_DIR)/$(MKDOSFS_TARGET_BINARY)
-endif
-
-ifeq ($(BR2_PACKAGE_DOSFSTOOLS_DOSFSCK),y)
-TARGETS+=$(TARGET_DIR)/$(DOSFSCK_TARGET_BINARY)
-endif
-
-ifeq ($(BR2_PACKAGE_DOSFSTOOLS_DOSFSLABEL),y)
-TARGETS+=$(TARGET_DIR)/$(DOSFSLABEL_TARGET_BINARY)
-endif
+ifeq ($(BR2_PACKAGE_DOSFSTOOLS),y)
+TARGETS+=dosfstools
+endif \ No newline at end of file