summaryrefslogtreecommitdiffstats
path: root/package/docker
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
commit77754571b2f327636ce0072cfabc9ce0c9a6ad86 (patch)
tree56fc2d3552653caaa20ee7577b1a04375f80bf28 /package/docker
parent344d59d788d697f4f6704dd920cad615318e47be (diff)
downloadbuildroot-novena-77754571b2f327636ce0072cfabc9ce0c9a6ad86.tar.gz
buildroot-novena-77754571b2f327636ce0072cfabc9ce0c9a6ad86.zip
pkgconfig: add pkgconfig package for target
The host versions shouldn't be visible in Kconfig, so remove the reference to BR2_PACKAGE_PKGCONFIG everywhere and prefix the host targets with host-. At the same time add pkgconfig for the target (E.G. for development) and let BR2_PACKAGE_PKGCONFIG control that package. Notice: all defconfigs in the tree have been updated, but make sure to disable the pkgconfig package (unless you want it) if you use an external config, otherwise you'll end up with pkgconfig and glib2 in the target.
Diffstat (limited to 'package/docker')
-rw-r--r--package/docker/Config.in1
-rw-r--r--package/docker/docker.mk2
2 files changed, 1 insertions, 2 deletions
diff --git a/package/docker/Config.in b/package/docker/Config.in
index b424c29c5..1c89a79c8 100644
--- a/package/docker/Config.in
+++ b/package/docker/Config.in
@@ -2,7 +2,6 @@ config BR2_PACKAGE_DOCKER
bool "docker"
depends on BR2_PACKAGE_XORG||BR2_PACKAGE_XORG7||BR2_PACKAGE_TINYX
select BR2_PACKAGE_LIBGLIB2
- select BR2_PACKAGE_PKGCONFIG
help
a system tray dock for X
diff --git a/package/docker/docker.mk b/package/docker/docker.mk
index fb4c4ecda..d86e88b3b 100644
--- a/package/docker/docker.mk
+++ b/package/docker/docker.mk
@@ -19,7 +19,7 @@ DOCKER_MAKE_OPT = CC=$(TARGET_CC) CXX=$(TARGET_CXX) LD=$(TARGET_LD) \
DOCKER_INSTALL_TARGET_OPT = PREFIX=$(TARGET_DIR)/usr install
-DOCKER_DEPENDENCIES = uclibc pkgconfig libglib2 $(XSERVER)
+DOCKER_DEPENDENCIES = uclibc host-pkgconfig libglib2 $(XSERVER)
$(eval $(call AUTOTARGETS,package,docker))