summaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-03-02 14:36:40 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-03-02 14:36:40 +0000
commitecd6931abeb60ca3b60762766c296506f8680efd (patch)
treedd9836bc0933a0232e7c59003a678f8365e383c7 /package/dnsmasq
parentbec2eba9edc06dea1dd68d03928fc4f646cbc603 (diff)
downloadbuildroot-novena-ecd6931abeb60ca3b60762766c296506f8680efd.tar.gz
buildroot-novena-ecd6931abeb60ca3b60762766c296506f8680efd.zip
dnsmasq: make tftp support optional
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Config.in8
-rw-r--r--package/dnsmasq/dnsmasq.mk14
2 files changed, 16 insertions, 6 deletions
diff --git a/package/dnsmasq/Config.in b/package/dnsmasq/Config.in
index 05e40f34e..ddf478240 100644
--- a/package/dnsmasq/Config.in
+++ b/package/dnsmasq/Config.in
@@ -6,3 +6,11 @@ config BR2_PACKAGE_DNSMASQ
coupled DNS and DHCP service to a LAN.
http://www.thekelleys.org.uk/dnsmasq/
+
+config BR2_PACKAGE_DNSMASQ_TFTP
+ bool "tftp support"
+ default y
+ depends on BR2_PACKAGE_DNSMASQ
+ help
+ Enable TFTP support in dnsmasq.
+
diff --git a/package/dnsmasq/dnsmasq.mk b/package/dnsmasq/dnsmasq.mk
index c209de60a..c5dbefaec 100644
--- a/package/dnsmasq/dnsmasq.mk
+++ b/package/dnsmasq/dnsmasq.mk
@@ -11,10 +11,14 @@ DNSMASQ_DIR:=$(BUILD_DIR)/dnsmasq-$(DNSMASQ_UPVER)
DNSMASQ_BINARY:=dnsmasq
DNSMASQ_TARGET_BINARY:=usr/sbin/dnsmasq
-ifneq ($(BR2_INET_IPV6),y)
-DNSMASQ_COPTS:=-DNO_IPV6
-else
DNSMASQ_COPTS:=
+
+ifneq ($(BR2_INET_IPV6),y)
+DNSMASQ_COPTS+=-DNO_IPV6
+endif
+
+ifneq ($(BR2_PACKAGE_DNSMASQ_TFTP),y)
+DNSMASQ_COPTS+=-DNO_TFTP
endif
$(DL_DIR)/$(DNSMASQ_SOURCE):
@@ -27,7 +31,7 @@ $(DNSMASQ_DIR)/.source: $(DL_DIR)/$(DNSMASQ_SOURCE)
$(DNSMASQ_DIR)/src/$(DNSMASQ_BINARY): $(DNSMASQ_DIR)/.source
$(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" \
- COPTS=$(DNSMASQ_COPTS) PREFIX=/usr -C $(DNSMASQ_DIR)
+ COPTS='$(DNSMASQ_COPTS)' PREFIX=/usr -C $(DNSMASQ_DIR)
$(TARGET_DIR)/$(DNSMASQ_TARGET_BINARY): $(DNSMASQ_DIR)/src/$(DNSMASQ_BINARY)
$(MAKE) DESTDIR=$(TARGET_DIR) PREFIX=/usr -C $(DNSMASQ_DIR) install
@@ -41,8 +45,6 @@ endif
dnsmasq: uclibc $(TARGET_DIR)/$(DNSMASQ_TARGET_BINARY)
-dnsmasq1: uclibc $(TARGET_DIR)/$(DNSMASQ_TARGET_BINARY)
-
dnsmasq-source: $(DL_DIR)/$(DNSMASQ_SOURCE)
dnsmasq-clean: