summaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2009-11-13 12:12:09 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2009-11-15 23:46:53 +0100
commit882e137608e2727f485014286bad6cdddc31a198 (patch)
tree11717876325e6adc4b8c4563371e69619d134979 /package/dnsmasq
parent83f9881d64cd7bcd760bc935e992e95ef3136b93 (diff)
downloadbuildroot-novena-882e137608e2727f485014286bad6cdddc31a198.tar.gz
buildroot-novena-882e137608e2727f485014286bad6cdddc31a198.zip
dnsmasq: bump to 2.51 and add IDN option
Closes #717 Dnsmasq 2.51 introduces IDN support, add it to the package. Newsworthy items: * Add support for internationalised DNS (IDN). * Improved upstream nameserver checks for slow nameservers. * Improved TFTP support (win/dos filenames, new tftpserver-address option for DHCP). Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Config.in8
-rw-r--r--package/dnsmasq/dnsmasq.mk9
2 files changed, 15 insertions, 2 deletions
diff --git a/package/dnsmasq/Config.in b/package/dnsmasq/Config.in
index 073f57b3c..a8d0d9a6e 100644
--- a/package/dnsmasq/Config.in
+++ b/package/dnsmasq/Config.in
@@ -20,3 +20,11 @@ config BR2_PACKAGE_DNSMASQ_DHCP
help
Enable DHCP server support in dnsmasq.
+config BR2_PACKAGE_DNSMASQ_IDN
+ bool "IDN support (BIG!)"
+ depends on BR2_PACKAGE_DNSMASQ
+ select BR2_PACKAGE_LIBINTL
+ select BR2_PACKAGE_LIBIDN
+ help
+ Enable IDN support in dnsmasq.
+ This option is a big space taker since is pulls in many libraries.
diff --git a/package/dnsmasq/dnsmasq.mk b/package/dnsmasq/dnsmasq.mk
index dec2971aa..07b3c484a 100644
--- a/package/dnsmasq/dnsmasq.mk
+++ b/package/dnsmasq/dnsmasq.mk
@@ -4,8 +4,7 @@
#
#############################################################
-DNSMASQ_VERSION = 2.50
-DNSMASQ_SOURCE = dnsmasq-$(DNSMASQ_VERSION).tar.gz
+DNSMASQ_VERSION = 2.51
DNSMASQ_SITE = http://thekelleys.org.uk/dnsmasq
DNSMASQ_AUTORECONF = NO
DNSMASQ_MAKE_ENV = CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)"
@@ -24,6 +23,12 @@ ifneq ($(BR2_PACKAGE_DNSMASQ_TFTP),y)
DNSMASQ_COPTS += -DNO_TFTP
endif
+ifeq ($(BR2_PACKAGE_DNSMASQ_IDN),y)
+DNSMASQ_MAKE_OPT += all-i18n
+DNSMASQ_DEPENDENCIES += libidn libintl
+DNSMASQ_MAKE_ENV += LDFLAGS+="-lintl"
+endif
+
ifneq ($(BR2_LARGEFILE),y)
DNSMASQ_COPTS += -DNO_LARGEFILE
endif