summaryrefslogtreecommitdiffstats
path: root/package/dmraid
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 23:18:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:26:50 +0200
commit020e028108d53c14ae257c8a643aa2d22ac00f4a (patch)
tree1f60c8120184c1beab97347b36bd15537edcf7f9 /package/dmraid
parent4dfe998b3252ac55e2c56e106e9f090b951191c6 (diff)
downloadbuildroot-novena-020e028108d53c14ae257c8a643aa2d22ac00f4a.tar.gz
buildroot-novena-020e028108d53c14ae257c8a643aa2d22ac00f4a.zip
dmraid: remove useless strip and use correct step override method
For the target installation step, do not rely on the package being installed in the staging directory, as it may not be true. So the dmraid binary is directly taken from the build directory. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/dmraid')
-rw-r--r--package/dmraid/dmraid.mk24
1 files changed, 7 insertions, 17 deletions
diff --git a/package/dmraid/dmraid.mk b/package/dmraid/dmraid.mk
index 93d6561f6..ccd6a3626 100644
--- a/package/dmraid/dmraid.mk
+++ b/package/dmraid/dmraid.mk
@@ -12,23 +12,13 @@ DMRAID_MAKE = $(MAKE1)
DMRAID_DEPENDENCIES:=lvm2
DMRAID_INSTALL_STAGING:=yes
-$(eval $(call AUTOTARGETS,package,dmraid))
-
-$(DMRAID_TARGET_INSTALL_TARGET): $(DMRAID_TARGET_INSTALL_STAGING)
- $(call MESSAGE,"Installing to target")
- $(INSTALL) -m 0755 $(STAGING_DIR)/usr/sbin/dmraid $(TARGET_DIR)/usr/sbin
+define DMRAID_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 $(@D)/$(DMRAID_SUBDIR)/tools/dmraid $(TARGET_DIR)/usr/sbin
$(INSTALL) -m 0755 package/dmraid/dmraid.init $(TARGET_DIR)/etc/init.d/dmraid
- touch $@
-
-ifeq ($(BR2_ENABLE_DEBUG),)
-$(DMRAID_HOOK_POST_INSTALL): $(DMRAID_TARGET_INSTALL_TARGET)
- $(STRIPCMD) $(STRIP_STRIP_ALL) $(TARGET_DIR)/usr/sbin/dmraid
- touch $@
-endif
+endef
-$(DMRAID_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
-# makefile has no uninstall target..
-# $(MAKE) DESTDIR=$(STAGING_DIR) -C $(DMRAID_DIR) uninstall
+define DMRAID_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/sbin/dmraid $(TARGET_DIR)/etc/init.d/dmraid
- rm -f $(DMRAID_TARGET_INSTALL_TARGET) $(DMRAID_HOOK_POST_INSTALL)
+endef
+
+$(eval $(call AUTOTARGETS,package,dmraid))