summaryrefslogtreecommitdiffstats
path: root/package/dmidecode
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-06-02 06:13:57 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-06-11 22:43:59 +0200
commit9d3547529b87ce3bddfcdc962e0c9d6d2b2ed9d5 (patch)
tree65e0d8c14cbbd9c0ce34766b13464da3dd9fc60e /package/dmidecode
parent83f43bab374535fe39d93547fb03c52fa45ab0a8 (diff)
downloadbuildroot-novena-9d3547529b87ce3bddfcdc962e0c9d6d2b2ed9d5.tar.gz
buildroot-novena-9d3547529b87ce3bddfcdc962e0c9d6d2b2ed9d5.zip
dmidecode: new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dmidecode')
-rw-r--r--package/dmidecode/Config.in9
-rw-r--r--package/dmidecode/dmidecode-build-system-fixes.patch35
-rw-r--r--package/dmidecode/dmidecode.mk18
3 files changed, 62 insertions, 0 deletions
diff --git a/package/dmidecode/Config.in b/package/dmidecode/Config.in
new file mode 100644
index 000000000..22272ed29
--- /dev/null
+++ b/package/dmidecode/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_DMIDECODE
+ bool "dmidecode"
+ depends on BR2_i386 || BR2_x86_64
+ help
+ Dmidecode reports information about your system's hardware
+ as described in your system BIOS according to the SMBIOS/DMI
+ standard.
+
+ http://www.nongnu.org/dmidecode/
diff --git a/package/dmidecode/dmidecode-build-system-fixes.patch b/package/dmidecode/dmidecode-build-system-fixes.patch
new file mode 100644
index 000000000..275f9df7f
--- /dev/null
+++ b/package/dmidecode/dmidecode-build-system-fixes.patch
@@ -0,0 +1,35 @@
+Minor build system fixes
+
+Usual build system fixes to allow CC/CFLAGS/LDFLAGS to be overriden
+from the command line, and completed by additional flags from the
+Makefile.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -12,9 +12,10 @@
+ # (at your option) any later version.
+ #
+
+-CC = gcc
+-CFLAGS = -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+- -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
++CC ?= gcc
++override CFLAGS += \
++ -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
++ -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
+ #CFLAGS += -DBIGENDIAN
+ #CFLAGS += -DALIGNMENT_WORKAROUND
+
+@@ -23,7 +24,7 @@
+ #CFLAGS += -g
+
+ # Pass linker flags here
+-LDFLAGS =
++override LDFLAGS +=
+
+ DESTDIR =
+ prefix = /usr/local
diff --git a/package/dmidecode/dmidecode.mk b/package/dmidecode/dmidecode.mk
new file mode 100644
index 000000000..a036a7a37
--- /dev/null
+++ b/package/dmidecode/dmidecode.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# dmidecode
+#
+#############################################################
+
+DMIDECODE_VERSION = 2.11
+DMIDECODE_SITE = http://download.savannah.gnu.org/releases/dmidecode/
+
+define DMIDECODE_BUILD_CMDS
+ $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define DMIDECODE_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) prefix=/usr DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(call GENTARGETS))