summaryrefslogtreecommitdiffstats
path: root/package/dmalloc
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-13 17:27:44 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-13 22:26:41 +0100
commit9eaad202f1579630598c160952da4b29e56d5bdb (patch)
tree226dc901ba77cb5ee26b048f080c006e7d3c57b7 /package/dmalloc
parenta72a670489547a3ca645ff7c3a0d9c3fb66eab51 (diff)
downloadbuildroot-novena-9eaad202f1579630598c160952da4b29e56d5bdb.tar.gz
buildroot-novena-9eaad202f1579630598c160952da4b29e56d5bdb.zip
toolchain: rework thread options
The selection of linuxthreads, linuxthreads old or NPTL doesn't make a lot of sense for external toolchains. So, instead, we : * Introduce an hidden BR2_TOOLCHAIN_HAS_THREADS option, which must be selected by toolchain specific options when thread support is available. Package needing to test thread support should use this option. * Move the none/linuxthreads/linuxthreads old/NPTL selection to Buildroot internal toolchain configuration. * Add an option in external toolchain to tell if thread support is available or not in the external toolchain. We assume that glibc without threads is not possible, as Ulrich Drepper said in http://sourceware.org/ml/libc-alpha/2005-08/msg00091.html ffmpeg, dmalloc and openvpn are fixed to use the new BR2_TOOLCHAIN_HAS_THREADS option. For openvpn, --enable-threads=posix is no longer used, as the configure script doesn't even understand this option. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dmalloc')
-rw-r--r--package/dmalloc/dmalloc.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/dmalloc/dmalloc.mk b/package/dmalloc/dmalloc.mk
index 60ad76393..dca0488d5 100644
--- a/package/dmalloc/dmalloc.mk
+++ b/package/dmalloc/dmalloc.mk
@@ -16,10 +16,10 @@ else
DMALLOC_CONF_OPT+=--disable-cxx
endif
-ifeq ($(BR2_PTHREADS_NONE),y)
-DMALLOC_CONF_OPT+=--disable-threads
-else
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
DMALLOC_CONF_OPT+=--enable-threads
+else
+DMALLOC_CONF_OPT+=--disable-threads
endif
define DMALLOC_POST_PATCH